[cairo] get-clip-svg-* test failures

Mike Emmel mike.emmel at gmail.com
Fri Sep 29 20:27:28 PDT 2006

On 9/29/06, Bryce Harrington <bryce at osdl.org> wrote:
> On Fri, Sep 29, 2006 at 04:07:35PM -0700, Carl Worth wrote:
> > Yes, this is a new test for a new feature, and the failure is a good
> > catch on the part of crucible, (crucible is obviously being more
> > diligent about running the test suite than I am, for example).
> >
> > The problem is that the test suite assumes that the backend will
> > always be able to provide the clip as a list of rectangles if the user
> > passes in a list of rectangles.
> Okay, great that it's a legit bug.  :-)  Let me know if there's a patch
> to be tested.
> > > Also, I've noticed a number of 'Failed to open display:' warnings; I
> > > have xorg installed on the test machines but not actually running.  Does
> > > the testsuite require X be up?
> >
> > In order to test cairo's xlib backend, then yes, it needs to be able
> > to talk to an X server. The "failed to open display" errors explain
> > the gray UNTESTED xlib column you are getting in your results.
> What approach would you recommend to run X on a headless box?  Or would
> it be worth the effort to set up?

Virtual fb driver with the framebuffer backend is pretty easy. IMHO

> Bryce
> _______________________________________________
> cairo mailing list
> cairo at cairographics.org
> http://cairographics.org/cgi-bin/mailman/listinfo/cairo

More information about the cairo mailing list