[cairo] Failed to compile cairo-1.8.8

M Joonas Pihlaja jpihlaja at cc.helsinki.fi
Wed Jun 24 12:49:33 PDT 2009

Hi Travis,

On Wed, 24 Jun 2009, Travis Lee wrote:

> Hi all,
> I'm new on Cairo and am seeking help...
> I cannot compile Cairo on Solaris SunOS 5.10.
> Here are the messages:


I believe these errors go away if you compile with GNU Make -- it 
seems we've picked up that dependency along the way.  You'll also find 
that the test suite doesn't compile on Solaris in 1.8.8 because we're 
using some BSD-derived functions and not linking to the socket 
libraries. There's been some work fairly recently to get the Solaris 
builds working better in the development branch, but that's still 
on-going.  (Most notably the cairo-trace tool needs some attention to 
make it less linux specific, and I hope that'll get done in time for 
the next stable release 1.10 as well.)  Anyway, for your problem, 
switching to GNU Make should sort you out.



More information about the cairo mailing list