[cairo] problem building cairo 1.10.0 for x86_64 on Mac OS X 10.5 (Leopard)

Kevin Layer layer at franz.com
Wed Nov 3 15:05:53 PDT 2010

Alexander Shulgin <alex.shulgin at gmail.com> wrote:

>> On Tue, Nov 2, 2010 at 01:36, Kevin Layer <layer at franz.com> wrote:
>> > I'm trying to build the universal version of gtk2, and in the process
>> > it tries to build cairo and gets the following error.  Is this a known
>> > problem?
>> >
>> > I have the latest Xcode for Leopard installed.  3.1.4.  The rest of
>> > the system is up to date, as well.
>> I have built cairo-1.10 on Snow Leopard (10.6.4) w/o a problem, both
>> x64 and i386 variants.  So this might be a problem with your version
>> of Xcode.  I'd try to check on the Apple developer site if there's any
>> updates/knwown issues to that.

I'm trying to build a universal binary with macports.  Clearly it
doesn't work, and the macports guys say it's a cairo problem.  I
really need a universal binary, and know of no other way to (easily)
build it.

Isn't there anything more that can be done?

Months ago I built one, and cairo built fine, so it's definitely a
change for the worse.



More information about the cairo mailing list