[cairo-announce] [ANNOUNCE] pixman release 0.15.14 now available

Soeren Sandmann sandmann at daimi.au.dk
Wed Jun 24 10:07:39 PDT 2009

A new pixman release 0.15.14 is now available. This is a development
release leading up to a stable 0.16.0 release. 


   - Support for PDF blend modes [Benjamin Otte, Carlos Garcia Campos].

   - NEON updates [Jonathan Morton].

   - Fix for an out-of-bounds memory read [Søren Sandmann Pedersen].

   - Refactoring and code cleanup [Søren Sandmann Pedersen].

Testing is appreciated as always. If you are a distribution, consider
adding this release to your development version if you have one.

If find a bug, please either send mail to cairo at cairographics.org, or
file a bug at:





        MD5:  bfbb075dd60402e86528add13f8e27ad  pixman-0.15.14.tar.gz
        MD5:  bb98ff30947c171f5e396b66f5714e2d  pixman-0.15.14.tar.bz2
        SHA1: 46065c0fee9f8c5bf63ce68ca1e03ff1ec7c2f80        pixman-0.15.14.tar.gz
        SHA1: a3155f5e286c11031adcf0056eee8a2b3c1f00b8        pixman-0.15.14.tar.bz2

GPG signature:
        (signed by Søren Sandmann Pedersen <sandmann at daimi.au.dk>)

        tag: pixman-0.15.14

        Benjamin Otte (24):
              Add support for extended blend mode. First pass.
              use a pixman_op_t here
              Add INVERT and SUBTRACT blend modes used in Flash
              use PDF algorithm for soft-light
              fix ColorDodge and ColorBurn to conform to the PDF spec
              add nonseperable blend modes from PDF spec
              remove invert operator
              prefix HSL operators with HSL
              clean up seperable blend modes
              rewrite nonseperable blend modes the same way as seperable ones
              add component-alpha versions of the seperable blend-modes
              add non-seperable versions for component alpha
              invent a Subtract operator for component alpha
              remove a leftover debugging statement
              remove semicolon at end of macro
              typo fix: Seperable => Separable
              rework blend-mode documentation to match current code better
              rename operator SUBTRACT to FLASH_SUBTRACT
              fix component-alpha versions for seperable blend modes
              fix comment
              fix Multiply component-alpha version
              correct subtract implementation
              remove debugging leftovers
              fix component-alpha versions to set source to 0 when mask is 0
        Carlos Garcia Campos (5):
              [TEST] Update composite-test to test more operators
              Fix typo
              Do not use combineMask in component-alpha functions
              Use floating point in SetLum
              Fix BlendColorBurn
        Jonathan Morton (3):
              [NEON] Replace Ian's glyph-blitter with a better one.
              [NEON] Add transparent rect blitter.
              [NEON] Add ARGB8-over-RGB565 compositing blitter.
        M Joonas Pihlaja (1):
              Remove redundant NULL checks from general_composite_rect().
        Michel Dänzer (1):
              Fix the build on big endian machines.
        Søren Sandmann Pedersen (92):
              Post-release version bump
              Eliminate trivial READ and WRITE macros in pixman-fast-path.c
              Remove dstMask from pixman-fast-path.c
              Remove unused pixmanFetchGradient() declaration
              Delete FbComposeData type
              Delete empty FASTCALL macro
              Rename bits_image.fetch_pixels_{32,64} to
              Delete unused CombineFunc{32,64} types
              Remove useless FbBits typedef
              Remove commented-out fbAddTriangles
              Delete unused IS_SOURCE_IMAGE() macro
              Rename GradientWalker to pixman_gradient_walker_t
              Rename PixmanTimer to pixman_timer_t
              Get rid of pixman_region_internal_set_static_pointers()
              Rename pixman-pict.c to pixman.c
              Only use force_align_arg_pointer on gcc/x86-32
              Rename combine.inc and combine.h.inc to pixman-combine.{c,h}.template.
              Eliminate MSBFirst, LSBFirst, IMAGE_BYTE_ORDER, and BITMAP_BIT_ORDER.
              Rename FastPathInfo to pixman_fast_path_t
              Move compiler dependencies to a new pixman-compiler.h file
              Move edge utilities into pixman-trap.c
              Use DIV instead of _div In pixman-trap.c.
              Move FbGen macro into pixman-combine.c
              Implement pixman_format_supported_destination() in terms
              Eliminate FbStipMask macro.
              Implement fbComposeGetSolid() as a call to pixman_image_get_scanline()
              Eliminate bit fiddling macros from pixman-private.h.
              Delete unused mod macro
              Move pixman_image_fill_rectangles() to pixman.c
              Delete unused WRITE_ACCESS() macro
              Turn fbComposeGetSolid() macro into a pixman_image_get_solid() function.
              Rename pixman_image_can_get_solid() to pixman_image_is_solid
              Replace switch functions in pixman-access.c with a table
              Implement fbStore_a2g2b2r2
              Delete FB_MASK and FB_ALLONES macros
              Move edge stepper macros into pixman-edge.c
              Delete obsolete comment
              Move some macros into pixman-access.c
              Move macros around in pixman-private.h
              Get rid of indexed argument to store functions
              Eliminate pointless Red/Green/Blue macros
              Move pixman_compute_composite_region() into pixman-utils.c
              Move pixman_version() to pixman.c
              Move code around
              Move region helpers into pixman-utils.c
              Delete struct point
              Some formatting changes
              Various minor changes
              Remove unused ACCESS macros in pixman-bits-image.c
              Eliminate Fetch/Store24 macros.
              Use fbOver() instead of fbOver24.
              Delete FbInU macro.
              Turn the FbAdd() macro into an FbIntAdd() which doesn't take a channel.
              Fix typo in CLIP macro.
              Make pixman-mmx.c compile again.
              Delete FbInOverC macro
              Move FbGet8() macro into pixman-bits-image.c
              Move accessor macros to their own header.
              Delete unused _pixman_image_get_fetcher() function
              Remove unused typedefs.
              Write alpha map fetching with FbByteMul() instead of div_255()
              Rename PIXMAN_FORMAT_16BPC macro to PIXMAN_FORMAT_IS_WIDE
              Add some comments about the linearity of the non-separable blend modes
              Fix various problems in FbCombineMultiplyC
              Fix some more problems in MultiplyC
              Remove optimizations that I'm not convinced are correct
              Fix ColorDodge and ColorBurn to conform to the spec
              Make the composite test window bigger by default.
              Add screen-test.c test program
              Remove FLASH_SUBTRACT blend mode.
              Remove support for component alpha with HSL blend modes.
              Delete leftover use of PIXMAN_OP_FLASH_SUBTRACT
              Add convolution-test.c program
              Subtract x_off/y_off before conversion to integer.
              Fix comment in pixman-utils to have the right sense.
              Add test case for out-of-bounds memory access.
              Fix typo in oob-test.c
              Fix offset bug in pixman_run_fast_path().
              Add a table to oob-test so that it can test more than one setup.
              Delete FbIntMult and FbIntDiv macros, and move FbIntAdd to pixman-combine
              Fix bug where 64 bit pixel were fetched as 32 bit ones.
              Get rid of casts to scanFetchProc in pixman-bits-image.c
              Get rid of scanFetchProc casts in pixman-conical-gradient.c
              Get rid of scanFetchProc casts in pixman-radial-gradient.c
              Get rid of remaining scanFetchProc casts
              Consolidate the three scanline store types into one.
              Get rid of the 64 bit fetcher types.
              Rename fetchProc32 to fetch_scanline_t and fetch_pixels_32_t to fetch_pix
              Add a mask and mask_bits argument to the raw scanline fetchers.
              Constify the mask argument to scanline fetchers.
              Delete scanFetchProc type. Use fetch_scanline_t instead.
              Pre-release version bump
        William Bonnet (1):
              Fix build on Sun Studio.

More information about the cairo-announce mailing list