[cairo-bugs] [Bug 17261] New: Problems between xfwm4, cairo and randr

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Oct 12 01:50:29 PDT 2008


           Summary: Problems between xfwm4, cairo and randr
           Product: cairo
           Version: 1.6.4
          Platform: x86-64 (AMD64)
        OS/Version: Linux (All)
            Status: RESOLVED
          Severity: normal
          Priority: medium
         Component: xlib backend
        AssignedTo: cworth at cworth.org
        ReportedBy: corsac at debian.org
         QAContact: cairo-bugs at cairographics.org

Chris Wilson <chris at chris-wilson.co.uk> changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|                            |NOTOURBUG


I have a weird problem which is hard to debug. This is the third bug I open,
first ones were against xfwm4 and murrine:


I'm using Xfce 4.4.2 on a laptop, and murrine engine 0.60~svn.

When I plug a VGA screen and do xrandr --auto, everything works fine and I get
the external screen as clone mode. Then I want to use the second screen to
extend my desktop, I do:

xrandr --output VGA --right-of LVDS

Then, the screen on the right correctly gets of clone mode, but nothing (or so)
is displayed there. I can see the mouse pointer, but that's all. I use
compositing on inactive and moving windows, so I tried disabling compositing on
xfwm4, and it worked, I could see the window on the right screen.

As murrine is a RGBA-enabled theme engine, I tried to switch theme, and use
xfce engine, with compositing, and it works too. So I reported the bug against
murrine, and Cimi helped me a bit. I tried Clearlooks, Crux and Industrial
themes, which are all cairo-based (which xfce engine is not), and it doesn't
work on any. Cimi thinks this can be related to cairo or intel xorg driver.

I have a related problems, where all “text” widgets (menus, menubar, labels
etc.) and “composited” widget disappear from time to time, at resume.
Sometime just putting the laptop to sleep again and having it back fixes the
problem, so I'll try to see with intel driver maintainers too.

Cheers and thanks for all the work.

--- Comment #1 from Yves-Alexis <corsac at debian.org>  2008-08-23 03:25:51 PST ---
*** Bug 17265 has been marked as a duplicate of this bug. ***

--- Comment #2 from Chris Wilson <chris at chris-wilson.co.uk>  2008-10-12 01:50:23 PST ---
Reading through the chain of bugs, this just seems like a driver failure
handling ARGB windows after an xrandr switch. cairo itself doesn't
discriminate, it is passed a drawable to which it sends a stream of XRender
requests (and if XRender doesn't support the request operation, then we grab a
copy of the drawable and perform the rendering in software and then copy the
result back to the drawable). So nothing in that sequence is ostensibly
different between the primary and the secondary displays.

Thanks for the bug report - I do hope it will be solved and you get to continue
enjoying Cairo!

Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the cairo-bugs mailing list