[cairo-bugs] [Bug 50412] New: [patch] add comment to explain _cairo_edge_compute_intersection_*, improve code readability
bugzilla-daemon at freedesktop.org
bugzilla-daemon at freedesktop.org
Sun May 27 16:43:00 PDT 2012
https://bugs.freedesktop.org/show_bug.cgi?id=50412
Bug #: 50412
Summary: [patch] add comment to explain
_cairo_edge_compute_intersection_*, improve code
readability
Classification: Unclassified
Product: cairo
Version: 1.12.2
Platform: All
OS/Version: All
Status: NEW
Severity: normal
Priority: medium
Component: general
AssignedTo: cworth at cworth.org
ReportedBy: dongsheng.xing at intel.com
QAContact: cairo-bugs at cairographics.org
diff --git a/src/cairo-fixed-private.h b/src/cairo-fixed-private.h
index b6cc6be..1956cf9 100644
--- a/src/cairo-fixed-private.h
+++ b/src/cairo-fixed-private.h
@@ -311,7 +311,7 @@ _cairo_fixed_mul_div_floor (cairo_fixed_t a, cairo_fixed_t
b, cairo_fixed_t c)
return _cairo_int64_32_div (_cairo_int32x32_64_mul (a, b), c);
}
-
+/* compute y from x so that (x,y), p1, and p2 are collinear */
static inline cairo_fixed_t
_cairo_edge_compute_intersection_y_for_x (const cairo_point_t *p1,
const cairo_point_t *p2,
@@ -332,6 +332,7 @@ _cairo_edge_compute_intersection_y_for_x (const
cairo_point_t *p1,
return y;
}
+/* compute x from y so that (x,y), p1, and p2 are collinear */
static inline cairo_fixed_t
_cairo_edge_compute_intersection_x_for_y (const cairo_point_t *p1,
const cairo_point_t *p2,
--
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA Contact for the bug.
More information about the cairo-bugs
mailing list