[cairo-bugs] [Bug 93281] _cairo_surface_is_snapshot() return error result on armcc on RVDS/MDK

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Dec 9 11:25:32 PST 2015


--- Comment #3 from Bryce Harrington <b.harrington at samsung.com> ---
Setting something like CAIRO_SURFACE_TYPE_IMAGE = 0x0000 to force the type
looks kind of kludgy to me.

Offhand I think Bill's right that the tested value should be added to the enum.
 In general casting enums from one to another seems crude; there's no way to be
sure that one day someone adds FOO as item 42 in one enum definition and
someone else adds BAR as 42 in the other, which mean completely different and
incompatible things?

If there's just a handful of enum casts, I'd say just fix them to work without
needing casts.  If this is used extensively throughout the codebase, this
probably needs further thought.

You are receiving this mail because:
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cairographics.org/archives/cairo-bugs/attachments/20151209/e7c302a1/attachment.html>

More information about the cairo-bugs mailing list