[cairo-bugs] [Bug 89339] util/cairo-script: compilation errors on AIX (no member named '__jmpbuf')

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Thu Jun 18 16:03:51 PDT 2015


Bryce Harrington <b.harrington at samsung.com> changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|---                         |FIXED

--- Comment #4 from Bryce Harrington <b.harrington at samsung.com> ---
commit b4a922f62d34973ea89495b40ce8bc6378110b9e
Author:     Bryce Harrington <bryce at osg.samsung.com>
AuthorDate: Tue Jun 16 16:42:56 2015 -0700
Commit:     Bryce Harrington <bryce at osg.samsung.com>
CommitDate: Thu Jun 18 12:38:59 2015 -0700

    cairo-script: Rename struct member to avoid name collision on AIX

    On AIX, the token jmpbuf is a pre-processor macro.
    cairo-script-scanner.c includes a private struct with a member named
    jmpbuf which gets renamed to __jmpbuf when AIX's sys/context.h has been

    While judicious ordering of includes might kludge around this problem
    (by causing all references to .jmpbuf to become .__jmpbuf), it's better
    to simply select a new name for the struct member that won't suffer the

    Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=89339

    Signed-off-by: Bryce Harrington <bryce at osg.samsung.com>
    Reviewed-by: Chris Wilson <chris at chris-wilson.co.uk>

You are receiving this mail because:
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cairographics.org/archives/cairo-bugs/attachments/20150618/69299b16/attachment.html>

More information about the cairo-bugs mailing list