[cairo-commit] cairo/test text_cache_crash.c,1.3,1.4

Carl Worth commit at pdx.freedesktop.org
Mon Dec 20 08:08:31 PST 2004

Committed by: cworth

Update of /cvs/cairo/cairo/test
In directory gabe:/tmp/cvs-serv24680/test

Modified Files:
Log Message:

        * test/text_cache_crash.c (draw): Disabled test that was killing
        my machine for some reason. Scary.

Index: text_cache_crash.c
RCS file: /cvs/cairo/cairo/test/text_cache_crash.c,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -d -r1.3 -r1.4
--- text_cache_crash.c	23 Nov 2004 21:38:09 -0000	1.3
+++ text_cache_crash.c	20 Dec 2004 16:08:29 -0000	1.4
@@ -83,8 +83,28 @@
     /* Then there was a bug that choked when selecting a font too big
      * for the cache. */
+/* XXX: Sometimes this leads to an assertion:
+_cairo_cache_lookup: Assertion `cache->max_memory >= (cache->used_memory + new_entry->memory)' failed.
+   But other times my machine hangs completely only to return to life
+   several minutes later with some programs missing. This seems like
+   the out-of-memory killer to me.
+   It seems like I usually get the assertion when I run
+   ./text_cache_crash directly and I usually get the machine hang when
+   I run "make check" but I don't know if there's a perfect
+   correlation there.
+   So there's a bad bug here somewhere that really needs to be fixed.
+   But in the meantime, I need "make check" not to destory work, so
+   I'm commenting this test out for now.
     cairo_scale_font (cr, 500);
     cairo_show_text (cr, "hello");

More information about the cairo-commit mailing list