[cairo-commit] cairo ChangeLog,1.257,1.258

Dave Beckett commit at pdx.freedesktop.org
Mon Nov 8 14:08:18 PST 2004


Committed by: dajobe

Update of /cvs/cairo/cairo
In directory gabe:/tmp/cvs-serv719

Modified Files:
	ChangeLog 
Log Message:
Restore the huge bit of ChangeLog I just deleted, then add my 6 lines.


Index: ChangeLog
===================================================================
RCS file: /cvs/cairo/cairo/ChangeLog,v
retrieving revision 1.257
retrieving revision 1.258
diff -u -d -r1.257 -r1.258
--- ChangeLog	8 Nov 2004 21:33:42 -0000	1.257
+++ ChangeLog	8 Nov 2004 22:08:16 -0000	1.258
@@ -612,7 +612,225 @@
 	trapezoids just by using offscreen drawing.
 	(_cairo_gl_surface_create_similar): Inherit anti-aliasing properties.
 
-	* src/cairo_gstate.c (_cairo_gstate_creat
+	* src/cairo_gstate.c (_cairo_gstate_create_pattern): Get solid color
+	from color stop components.
+
+	* src/cairoint.h: Removed cairo color from color stop.
+
+	* src/cairo_pattern.c: Added MULTIPLY_COLORCOMP macro.
+	(cairo_pattern_add_color_stop): Do not pre-multiply stop color.
+	(_cairo_pattern_calc_color_at_pixel): Multiply with alpha.
+
+2004-05-28  Carl Worth  <cworth at isi.edu>
+
+	* These two fixes are from David Reveman <c99drn at cs.umu.se>:
+
+	* src/cairo_surface.c (_cairo_surface_create_similar_scratch)
+	(_cairo_surface_create_similar_solid): Move NULL test from
+	create_similar_scratch to create_similar_solid.
+	
+	* src/cairo_font.c (_cairo_glyph_surface_init): Fix for when
+	surface->backend != image->backend, but the backend does use
+	images for similar surfaces.
+
+2004-05-28  Keith Packard  <keithp at keithp.com>
+
+	* configure.in:
+	* src/Makefile.am:
+	Add WARN_CFLAGS, autodetection for 64/128 bit ints and
+	cairo_wideint.[ch]
+	
+	* src/cairo_gstate.c: (_cairo_gstate_show_glyphs):
+	Check status return from _cairo_gstate_glyph_extents
+	
+	* src/cairo_pattern.c: (_cairo_image_data_set_radial),
+	(_cairo_pattern_get_image):
+	* src/cairo_png_surface.c: (_cairo_png_surface_copy_page):
+	* src/cairo_surface.c: (_cairo_surface_composite):
+	Quiet compiler warnings about uninitialized variables
+
+	* src/cairo_traps.c: (_det16_32), (_det32_64),
+	(_fixed_16_16_to_fixed_32_32), (_line_segs_intersect_ceil):
+	Switch to alternate exact line intersection code.
+	
+	* src/cairo_wideint.c: (_cairo_uint64_divrem),
+	(_cairo_uint32_to_uint64), (_cairo_int32_to_int64),
+	(_cairo_uint32s_to_uint64), (_cairo_uint64_add),
+	(_cairo_uint64_sub), (_cairo_uint32x32_64_mul),
+	(_cairo_uint64_mul), (_cairo_uint64_lsl), (_cairo_uint64_rsl),
+	(_cairo_uint64_rsa), (_cairo_uint64_lt), (_cairo_uint64_eq),
+	(_cairo_int64_lt), (_cairo_uint64_not), (_cairo_uint64_negate),
+	(_cairo_leading_zeros32), (_cairo_uint64x32_normalized_divrem),
+	(_cairo_int64_divrem), (_cairo_uint128_divrem),
+	(_cairo_uint32_to_uint128), (_cairo_int32_to_int128),
+	(_cairo_uint64_to_uint128), (_cairo_int64_to_int128),
+	(_cairo_uint128_add), (_cairo_uint128_sub), (uint64_lo),
+	(uint64_hi), (uint64_shift32), (_cairo_uint64x64_128_mul),
+	(_cairo_uint128_mul), (_cairo_uint128_lsl), (_cairo_uint128_rsl),
+	(_cairo_uint128_rsa), (_cairo_uint128_lt), (_cairo_int128_lt),
+	(_cairo_uint128_eq), (_cairo_uint128x64_normalized_divrem),
+	(_cairo_leading_zeros64), (_cairo_int128_negate),
+	(_cairo_int128_not), (_cairo_int128_divrem):
+	* src/cairo_wideint.h:
+	Add 64/128-bit wide integer arithmetic.
+	
+	* src/cairoint.h:
+	Switch to stdint.h types (and new wide types).
+
+2004-05-24  David Reveman  <c99drn at cs.umu.se>
+
+	* src/cairo.c (cairo_restore): Moved CAIRO_CHECK_SANITY below
+	declarations.
+	(cairo_current_font): Moved CAIRO_CHECK_SANITY below declarations.
+
+	* src/cairoint.h: Added cairo_glyph_size_t, cairo_glyph_surface_t,
+	cairo_glyph_surface_node_t and cairo_glyph_cache_t.
+	Added font backend functions text_bbox, glyph_bbox and create_glyph.
+	Added source offset parameter to show_text and show_glyphs.
+	Added drawable parameter to backend function create_similar.
+	cairo_font_t now contains a glyph_cache pointer.
+	Added _cairo_font_text_bbox, _cairo_font_glyph_bbox,
+	_cairo_font_lookup_glyph and _cairo_surface_create_similar_scratch.
+
+	* src/cairo_xlib_surface.c (_cairo_xlib_surface_create_similar): 
+	(_cairo_xlib_surface_clone_similar): 
+	Added drawable parameter to backend function create_similar.
+
+	* src/cairo_xcb_surface.c (_cairo_xcb_surface_create_similar): 
+	(_cairo_xcb_surface_clone_similar): 
+	Added drawable parameter to backend function create_similar.
+
+	* src/cairo_surface.c: Added _cairo_surface_create_similar_scratch.
+	Added drawable parameter to backend function create_similar.
+
+	* src/cairo_ps_surface.c (_cairo_ps_surface_create_similar): 
+	Added drawable parameter to backend function create_similar.
+
+	* src/cairo_png_surface.c (_cairo_png_surface_create_similar): 
+	Added drawable parameter to backend function create_similar.
+
+	* src/cairo_image_surface.c (_cairo_image_surface_create_similar): 
+	Added drawable parameter to backend function create_similar.
+
+	* src/cairo_gstate.c (_cairo_gstate_show_text): Use new text
+	bounding box function. Pass pattern source offset to show_text.
+	(_cairo_gstate_show_glyphs): Use new text
+	bounding box function. Pass pattern source offset to show_glyps.
+
+	* src/cairo_gl_surface.c (_cairo_gl_surface_create_similar): Added
+	drawable parameter to backend function create_similar. Use glitz's
+	new create similar interface. Support for read-only surfaces.
+	(_cairo_gl_surface_clone_similar): Added drawable parameter to
+	backend function create_similar.
+
+	* src/cairo_ft_font.c: Use new glyph caching system. Added bounding box
+	font backend functions.
+
+	* src/cairo_font.c: Added glyph caching system. Added bounding box
+	font backend functions.
+	(_cairo_font_init): Create new glyph cache.
+	(_cairo_font_copy): Take a reference to other fonts glyph cache.
+	(_cairo_font_show_text):
+	(_cairo_font_show_glyphs): Handle source offset.
+	(cairo_font_destroy): Destroy glyph cache.
+
+2004-05-20  Graydon Hoare  <graydon at redhat.com>
+
+	* configure.in: Add sanity checking feature configury.
+
+	* src/cairo-features.h.in: Add sanity checking feature.
+
+	* src/cairo.c: Add sanity checking.
+
+	* src/cairoint.h: Add prototypes.
+
+	* src/cairo_fixed.c 
+	(_cairo_fixed_is_integer): 
+	(_cairo_fixed_integer_part): New functions.
+
+	* src/cairo_matrix.c 
+	(_cairo_matrix_is_integer_translation): New function.
+
+	* src/cairo_gstate.c
+	(extract_transformed_rectangle): Use fixed functions.
+	(_cairo_gstate_clip): Arithmetic fixes.
+	(_cairo_gstate_clip_and_composite_trapezoids):
+	(_cairo_gstate_show_surface):
+	(_cairo_gstate_show_text):
+	(_cairo_gstate_show_glyphs): Corrections to clipping.
+
+	* src/cairo_xlib_surface.c
+	(_cairo_xlib_surface_composite): Add XCopyArea fast path.
+	(_cairo_xlib_surface_set_clip_region): Drive clip to drawable.
+
+2004-05-17  Carl Worth  <cworth at isi.edu>
+
+	* src/cairo.c (cairo_show_text): Do nothing when passed a NULL
+	string.
+
+2004-05-11  Øyvind Kolås  <oeyvindk at hig.no>
+	
+	* src/cairoint.h : changed CAIRO_FILTER_DEFAULT to CAIRO_FILTER_BEST
+	to make gradients easier.
+
+2004-05-11  David Reveman  <c99drn at cs.umu.se>
+
+	* src/cairo_pattern.c (_cairo_pattern_get_image): Removed
+	pattern_offset.
+
+	* src/cairo_surface.c (_cairo_surface_create_pattern): Removed
+	pattern_offset.
+
+	* src/cairo_gstate.c: Removed pattern_offset.
+
+	* src/cairoint.h: Removed pattern_offset.
+
+2004-05-11  Carl Worth  <cworth at isi.edu>	
+
+	* configure.in: Increment CAIRO_VERSION to 0.1.23.
+
+	* NEWS: Added notes for snapshot 0.1.23.
+
+	* RELEASING: Add reminder to mention incompatible API changes in
+	NEWS. Re-order steps to avoid clobbering pre-existing tar
+	files.
+
+2004-05-11  Carl Worth  <cworth at isi.edu>
+
+	* BUGS: Several people have reported that cairo_clip is not
+	working right now. And it's always been slow.
+
+2004-05-11  David Reveman  <c99drn at cs.umu.se>
+
+	* configure.in: Require glitz 0.1.2.
+
+	* src/cairo_gl_surface.c: Added opacity attribute. Fixed broken
+	CAIRO_GL_COMPOSITE_TRAPEZOIDS_SUPPORT macro.
+	(_cairo_gl_surface_composite_trapezoids): Use polygon opacity.
+	(_cairo_gl_surface_create_pattern): Added surface pattern support.
+	(_cairo_gl_surface_create): Initialize opacity to 0xffff.
+
+2004-05-07  Carl Worth  <cworth at isi.edu>
+
+	* src/cairo_ft_font.c (_utf8_to_ucs4): Bail on NULL utf8 string.
+
+	* src/cairo_spline.c (_cairo_spline_add_point): Don't add two
+	consecutive, identical points when decomposing the spline, (which
+	was leading to an infinte loop in the stroke algorithm when it
+	found a slope of (0,0)).
+
+2004-05-04  Carl Worth  <cworth at isi.edu>
+
+	* src/cairo_png_surface.c (cairo_png_surface_create): Move all
+	libpng-related code into copy_page.
+	(unpremultiply_data): Add missing unpremultiply step.
+	(_cairo_png_surface_copy_page): Move PNG output to copy_page. Add
+	support for A8 and A1 images. Remove time from header (we may want
+	to add it again later, but for now it messes up my test suite).
+	(_cairo_png_surface_destroy): Call copy_page if it hasn't been
+	called already.
+	(_cairo_png_surface_show_page): Add implementation.
+	(_cairo_png_surface_copy_page): Don't close a file we didn't open.
 
 2004-05-04  David Reveman  <c99drn at cs.umu.se>
 
@@ -1888,134 +2106,7 @@
 	* src/cairo_font.c (_cairo_font_create): Rename
 	_cairo_font_create_font and move to top of file.
 	(_cairo_font_init, _cairo_font_scale, _cairo_font_transform)
-	(_cairo_font_text_extents, _cairo_font_glyph_extents)
-	(_cairo_font_show_text, _cairo_font_show_glyphs)
-	(_cairo_font_text_path, _cairo_font_glyph_path)
-	(_cairo_font_font_extents): These internal functions can never be
-	called with a NULL font.
-
-2003-10-23  Graydon Hoare <graydon at redhat.com>
-
-	* src/cairo_ft_font.c: New file.
-	* src/Makefile.am: Add cairo_ft_font.c
-	* src/cairo.c: 
-	* src/cairo.h:
-	* src/cairo_font.c:
-	* src/cairo_gstate.c:
-	* src/cairo_xlib_surface.c:
-	* src/cairoint.h: Change to virtual font interface.
-
-2003-10-23  Carl Worth  <cworth at isi.edu>
-
-	* TODO: Added notes on some missing functions. Update PostScript
-	comparison with respect ot new arc functions.
-
-2003-10-23  Carl Worth  <cworth at isi.edu>
-
-	* Many files: Fixed Copyright statements to read "University of
-	Southern California" rather than "USC, Information Sciences
-	Institute" as the university is the actual corporation.
-
-2003-10-11  Carl Worth  <cworth at isi.edu>
-
-	* src/cairo-xlib.h: Add extern "C" stuff. (Thanks to Soory Kuloor
-	for the reminder).
-
-2003-10-09  Carl Worth  <cworth at isi.edu>
-
-	* src/cairo_font.c: Stub out NULL_POINTER errors as
-	CAIRO_STATUS_SUCCESS so that drawing to off-screen images still
-	works even though text does not yet.
-
-2003-10-04  Carl Worth  <cworth at isi.edu>
-
-	* src/cairo_hull.c (_cairo_hull_compute): Add cairo_hull.c to
-	compute a convex hull, (using Graham scan algorithm).
-
-	* src/cairo_pen.c (_cairo_pen_add_points): Generate convex hull of
-	pen after adding new points.
-
-	* src/cairoint.h: Rename pen->vertex to pen->vertices
-
-	* Replaced "pt" with "point" in about a zillion places.
-
-	* src/cairo.c (cairo_destroy): Fix to continue with destroy even
-	in the face of non-zero status.
-	(cairo_set_target_surface):
-	(cairo_set_target_image): Don't do anything even if cr->status is
-	CAIRO_STATUS_NO_TARGET_SURFACE.
-	(cairo_status_string): Report "<unknown error status>" rather than
-	en empty string.
-
-2003-10-01  Carl Worth  <cworth at isi.edu>
-
-	* src/cairo_gstate.c (_cairo_gstate_init_copy): Don't choke if
-	asked to copy a gstate with a NULL font.
-
-	* src/cairo_font.c (_cairo_font_init): 
-	(_cairo_font_init_copy): 
-	(_cairo_font_copy): 
-	(_cairo_font_fini): 
-	(_cairo_font_select): 
-	(_cairo_font_scale): 
-	(_cairo_font_transform): 
-	(_cairo_font_text_extents): 
-	(_cairo_font_show_text): Return immediately if passed a NULL pointer.
-
-2003-09-30  Jamey Sharp  <jamey at minilop.net>
-
-	* src/Makefile.am, src/cairo.c, src/cairo.h, src/cairo_font.c,
-	src/cairo_gstate.c, src/cairo_surface.c, src/cairoint.h:
-	Virtualized font and surface backends. All Xlib/Xft calls are in
-	cairo_xlib_surface.c/cairo-xlib.h now. Resolves a TODO item.
-
-2003-09-30  Carl Worth  <cworth at east.isi.edu>
-
-	* src/cairo.c (cairo_copy): Don't copy a gstate if src->status != 0.
-
-	* src/cairo_gstate.c (_cairo_gstate_init_copy): Be careful to
-	preserve gstate->next.
-	(_cairo_gstate_copy): New function to support cairo_copy.
-
-	* src/cairo.c (cairo_copy): Fixed horribly botched implementation
-	of cairo_copy.
-
-	* configure.in: Bumped version to 0.1.7 to indicate change in
-	cairo_copy.
-
-	* src/cairo.c (cairo_copy): Changed cairo_copy to copy graphics
-	state from one cairo_t to another rather than allocating a new
-	cairo_t.
-
-	* src/cairo_surface.c (cairo_surface_destroy):
-	(cairo_surface_create_similar_solid): Fix to delay XFreePixmap
-	until cairo_surface_destroy.
-
-2003-09-29  Carl Worth  <cworth at east.isi.edu>
-
-	* TODO: Remove arc notes since arcs are done.
-
-	* src/cairo_surface.c (_cairo_surface_composite): Fix bug
-	(IcImageGetHeight instead of IcImageGetWidth) from Graydon Hoare
-	<graydon at redhat.com>.
-
-2003-09-29  Carl Worth  <cworth at isi.edu>
-
-	* configure.in (CAIRO_VERSION): Bumpred version to 0.1.6 to
-	indicate new cairo_arc and cairo_arc_negative.
-
-	* src/cairo_gstate.c (_arc_error_normalized):
-	(_arc_max_angle_for_tolerance_normalized):
-	(_cairo_gstate_arc_segments_needed):
-	(_cairo_gstate_arc_segment):
-	(_cairo_gstate_arc_dir):
-	(_cairo_gstate_arc):
-	(_cairo_gstate_arc_negative): Several new functions to implement
-	arc support.
-
-	* src/cairo.h: Added cairo_arc and cairo_arc_negative.
-
-	* src/cairo.c (cairo_arc): 
+	(_cairo_font_text_e
 	(cairo_arc_negative): Added new arc support.
 
 2003-09-27  Carl Worth  <cworth at isi.edu>	




More information about the cairo-commit mailing list