[cairo-commit] cairo ChangeLog,1.433,1.434

Kristian Hogsberg commit at pdx.freedesktop.org
Wed Mar 16 12:08:43 PST 2005


Committed by: krh

Update of /cvs/cairo/cairo
In directory gabe:/tmp/cvs-serv32617

Modified Files:
	ChangeLog 
Log Message:
2005-03-16  Kristian Høgsberg  <krh at redhat.com>

        * src/Makefile.am: Add cairo_output_stream.c

        * src/cairo.h: Add new errors, CAIRO_STATUS_WRITE_ERROR and
        CAIRO_STATUS_SURFACE_FINISHED, add cairo_surface_finish()
        prototype, add cairo_write_func_t.

        * src/cairo.c: Add strings for new errors, documentation fix.

        * src/cairo_win32_surface.c:
        * src/cairo_xcb_surface.c:
        * src/cairo_xlib_surface.c:
        * src/cairo_glitz_surface.c:
        * src/cairo_image_surface.c:
        * src/cairo_png_surface.c:
        * src/cairo_ps_surface.c: Rename surface destroy functions to
        finish and change them to not free the surface.

        * src/cairo-pdf.h:
        * src/cairo_pdf_surface.c: Change PDF surface constructors to take
        a write function in the general case and add stdio convenience
        constructors.  Change destroy function to finish for
        cairo_pdf_surface.  Change implementation to use
        cairo_output_stream_t functions for output.

        * src/cairo_font.c: (_cairo_font_show_glyphs): Use
        _cairo_surface_show_glyphs instead of calling function pointer
        directly.

        * src/cairoint.h: Add prototypes for cairo output stream
        functions, rename destroy to finish in cairo_surface_backend_t and
        add finished flag to cairo_surface_t.

        * src/cairo_surface.c: Add cairo_surface_finish() and call it from
        cairo_surface_destroy().  Check the finished flag in
        cairo_surface_t in functions that change the surface.



Index: ChangeLog
===================================================================
RCS file: /cvs/cairo/cairo/ChangeLog,v
retrieving revision 1.433
retrieving revision 1.434
diff -u -d -r1.433 -r1.434
--- ChangeLog	16 Mar 2005 00:25:30 -0000	1.433
+++ ChangeLog	16 Mar 2005 20:08:41 -0000	1.434
@@ -1,3 +1,41 @@
+2005-03-16  Kristian Høgsberg  <set EMAIL_ADDRESS environment variable>
+
+	* src/Makefile.am: Add cairo_output_stream.c
+
+	* src/cairo.h: Add new errors, CAIRO_STATUS_WRITE_ERROR and
+	CAIRO_STATUS_SURFACE_FINISHED, add cairo_surface_finish()
+	prototype, add cairo_write_func_t.
+
+	* src/cairo.c: Add strings for new errors, documentation fix.
+	
+	* src/cairo_win32_surface.c:
+	* src/cairo_xcb_surface.c:
+	* src/cairo_xlib_surface.c:
+	* src/cairo_glitz_surface.c:
+	* src/cairo_image_surface.c:
+	* src/cairo_png_surface.c:
+	* src/cairo_ps_surface.c: Rename surface destroy functions to
+	finish and change them to not free the surface.
+	
+	* src/cairo-pdf.h:
+	* src/cairo_pdf_surface.c: Change PDF surface constructors to take
+	a write function in the general case and add stdio convenience
+	constructors.  Change destroy function to finish for
+	cairo_pdf_surface.  Change implementation to use
+	cairo_output_stream_t functions for output.
+	
+	* src/cairo_font.c: (_cairo_font_show_glyphs): Use
+	_cairo_surface_show_glyphs instead of calling function pointer
+	directly.
+	
+	* src/cairoint.h: Add prototypes for cairo output stream
+	functions, rename destroy to finish in cairo_surface_backend_t and
+	add finished flag to cairo_surface_t.
+	
+	* src/cairo_surface.c: Add cairo_surface_finish() and call it from
+	cairo_surface_destroy().  Check the finished flag in
+	cairo_surface_t in functions that change the surface.
+
 2005-03-15  Owen Taylor  <otaylor at redhat.com>
 
 	* src/cairo-xlib.h src/cairo_xlib_surface.c: Rework set




More information about the cairo-commit mailing list