[cairo-commit] [cairo-www] 3 commits - src/news src/roadmap.mdwn

Carl Worth cworth at freedesktop.org
Wed Jan 30 05:49:52 PST 2008


 src/news/cairo-1.5.8.mdwn |  145 ++++++++++++++++++++++++++++++++++++++++++++++
 src/roadmap.mdwn          |   18 ++---
 2 files changed, 153 insertions(+), 10 deletions(-)

New commits:
commit 9c7be3fb92d6fc0b0931800313ae2b9cdfc27096
Author: Carl Worth <cworth at cworth.org>
Date:   Wed Jan 30 05:48:25 2008 -0800

    Add news for cairo 1.5.8

diff --git a/src/news/cairo-1.5.8.mdwn b/src/news/cairo-1.5.8.mdwn
new file mode 100644
index 0000000..17a0f8a
--- /dev/null
+++ b/src/news/cairo-1.5.8.mdwn
@@ -0,0 +1,145 @@
+[[meta title="cairo 1.5.8 snapshot available"]]
+[[meta date="2008-01-30"]]
+
+	From: Carl Worth <cworth at cworth.org>
+	Date: Wed, 30 Jan 2008 05:44:02 -0800
+	To: cairo-announce at cairographics.org
+	Cc: gnome-announce-list at gnome.org
+	Subject: cairo snapshot 1.5.8 now available
+	
+	A new cairo snapshot 1.5.8 is now available from:
+	
+	        http://cairographics.org/snapshots/cairo-1.5.8.tar.gz
+	
+	    which can be verified with:
+	
+	        http://cairographics.org/snapshots/cairo-1.5.8.tar.gz.sha1
+	        8ab70db0eec1db3b730537d9076ddabf7e0ba537  cairo-1.5.8.tar.gz
+	
+	        http://cairographics.org/snapshots/cairo-1.5.8.tar.gz.sha1.asc
+	        (signed by Carl Worth)
+	
+	  Additionally, a git clone of the source tree:
+	
+	        git clone git://git.cairographics.org/git/cairo
+	
+	    will include a signed 1.5.8 tag which points to a commit named:
+	        4ccb8cb29546432858e778e1b88cada1327f6f45
+	
+	    which can be verified with:
+	        git verify-tag 1.5.8
+	
+	    and can be checked out with a command such as:
+	        git checkout -b build 1.5.8
+	
+	This is the fourth snapshot in cairo's unstable 1.5 series. It comes 2
+	weeks after the 1.5.6 snapshot. It adds a few new API functions. Most
+	notably all callers of cairo_image_surface_create_for_data should now
+	be calling cairo_format_stride_for_width to compute a legal stride
+	value.
+	
+	With this snapshot we are getting extrmely close to a final 1.6.0
+	release. We would appreciate as much testing as possible so that we
+	can eliminate bugs before that release rather than after. So give this
+	snapshot a try and let us know how things go for you.
+	
+	And have fun with cairo!
+	
+	-Carl
+	
+	Changes in cairo 1.5.8 since 1.5.6
+	==================================
+	New API in cairo 1.5.8
+	----------------------
+	We've added a new function that should be called to compute a legal
+	stride value before allocating data to be used with
+	cairo_image_surface_create_for_data:
+	
+		int
+		cairo_format_stride_for_width (cairo_format_t	format,
+					       int		width);
+	
+	We've also added a new cairo_path_extents function that can be used to
+	compute a bounding box for geometry such as a single line segment,
+	(contrast with cairo_path_extents and cairo_stroke_extents):
+	
+		void
+		cairo_path_extents (cairo_t *cr,
+				    double *x1, double *y1,
+				    double *x2, double *y2);
+	
+	And finally, we've added a function to allow for querying the
+	XRenderPictFormat of a cairo-xlib surface:
+	
+		XRenderPictFormat *
+		cairo_xlib_surface_get_xrender_format (cairo_surface_t *surface);
+	
+	API changes
+	-----------
+	Fix return types of cairo_surface_show_page and
+	cairo_surface_copy_page. This is an API change to functions that are
+	new in the 1.5 series, so not an API break compared to any stable
+	cairo release, (1.0.x, 1.2.x, 1.4.x).
+	
+	Change the return type of cairo_get_current_point() from void to
+	cairo_status_t. This allows the caller to receive a
+	CAIRO_STATUS_NO_CURRENT_POINT value to distinguish the a current point
+	at the origin from no current point existing.
+	
+	Performance improvement
+	-----------------------
+	Improve performance of clipping by using an optimized code path
+	internally, (with the ADD operator instead of IN).
+	
+	General bug fixes
+	-----------------
+	Fix various cairo_*_extents functions to initialize the return-value
+	variables even in the case of a cairo_t in error.
+	
+	Treat NULL as a legitimate value for cairo_font_options_t*. [XXX: On
+	discussion afterwards, we decided against this change so we plan to
+	remove this again before 1.6.0]
+	
+	Fix rendering with CAIRO_ANTIALIAS_NONE to be more predictable, (that
+	is, to avoid seams appearing when geometry and imagery share an
+	identical edge). Portions of this fix are in the pixman library and
+	will appear in a future release of that library.
+	
+	Avoid triggering an error for a font size of 0.
+	
+	Miscellaneous changes
+	---------------------
+	Require pixman >= 0.9.6.
+	
+	There has been a tremendous amount improvement to cairo's
+	documentation. We're delighted that 100% of the public API has at
+	least some documentation in the API reference manual. Many thanks to
+	Behdad Esfahbod and Nis Martensen for leading this effort.
+	
+	cairo-pdf and cairo-ps
+	----------------------
+	Eliminate failure when a Type 1 font is embedded with an explicit
+	glyph 0.
+	
+	cairo-pdf
+	---------
+	Implement a more correct and more efficient approach for patterns with
+	an extend mode of CAIRO_EXTEND_REFLECT.
+	
+	cairo-ps
+	--------
+	Fix image masks to properly pack and pad mask bits.
+	
+	cairo-quartz
+	------------
+	Take care to only use DrawTiledImage for integer-aligned images, (and
+	use slower paths to get the correct result in other cases).
+	
+	cairo-win32
+	-----------
+	Fix for older versions of mingw.
+	
+	Improve the handling of the clipping with the win32 and win32-printing
+	surfaces.
+	
+	Fix rendering of non black/white text.
commit 98f61b14fd459b841686855f0f5e5a9f2c793f52
Author: Carl Worth <cworth at cworth.org>
Date:   Sun Jan 27 12:16:14 2008 -0800

    roadmap: Indicate that cairo_xlib_surface_get_xrender_format has been added

diff --git a/src/roadmap.mdwn b/src/roadmap.mdwn
index b226fc0..d564ec0 100644
--- a/src/roadmap.mdwn
+++ b/src/roadmap.mdwn
@@ -37,6 +37,11 @@ abgr8888) (in 1.5.2)
    providing cairo_image_surface_stride_for_width to compute a legal
    stride).
 
+ ✓ New cairo-xlib-xrender API (cworth):
+
+	XRenderPictFormat *
+	cairo_xlib_surface_get_xrender_format (cairo_surface_t *surface);
+
 ## In-progress
 
  • Implement `CAIRO_EXTEND_PAD` for surface patterns (aazar)
@@ -53,11 +58,6 @@ abgr8888) (in 1.5.2)
 	 4945 Cairo doesn't support 8-bit pseudocolor visuals
 	 9719 Cairo doesn't support 655 xlib format
 
- • New cairo-xlib-xrender API (cworth):
-
-	XRenderPictFormat *
-	cairo_xlib_surface_get_xrender_format (cairo_surface_t *surface);
-
  • Change from 16.16 to 24.8 for fixed-point storage (vlad, cworth)
 
  • Fix generation of inefficient PostScript that crashes some printers (adrianj). See the mailing list thread:
commit 9b932b38e0de75bb48e69210138ee865aee74539
Author: Carl Worth <cworth at cworth.org>
Date:   Sun Jan 27 09:55:53 2008 -0800

    roadmap: Indicate that the a8mask problem has been addressed

diff --git a/src/roadmap.mdwn b/src/roadmap.mdwn
index 4ad6005..b226fc0 100644
--- a/src/roadmap.mdwn
+++ b/src/roadmap.mdwn
@@ -32,14 +32,12 @@ abgr8888) (in 1.5.2)
 
  ✓ `cairo_ps_surface_set_eps` (in 1.5.2)
 
-## In-progress
-
- • Fix a8mask failure, (pixman issue, cworth).
+ ✓ Fix a8mask failure, (pixman issue, ssp, cworth). Fixed by
+   documenting that only certain stride values are legal, (and
+   providing cairo_image_surface_stride_for_width to compute a legal
+   stride).
 
-   There is an [a8mask patch][] available on the list, but it may need
-   more work.
-
-   [a8mask patch]: http://lists.freedesktop.org/archives/cairo/2007-February/009737.html
+## In-progress
 
  • Implement `CAIRO_EXTEND_PAD` for surface patterns (aazar)
 


More information about the cairo-commit mailing list