[Cairo] Re: [Xr] Cairo
torgeir at pobox.com
Tue Jul 15 16:31:38 PDT 2003
On Wed, 2003-07-16 at 00:19, Keith Packard wrote:
> Around 0 o'clock on Jul 16, Torgeir Veimo wrote:
> > Ohh, this will feel a bit strange to code with. Can't it be cr_move_to
> > etc instead?
> It could be, but I'm concerned that this short prefix will collide with
> some existing facility in some operating system. The longer prefix seems
> less likely to cause problems. Remember that cairo is intended to be a
> cross-platform library, and so it will come in contact with a lot of
> other libraries; keeping the namespace easily separated should reduce
> future troubles.
> Also, given the short argument lists and brief function names, I was
> thinking that a longer prefix wouldn't be too bad.
> What do you think?
It probably just takes a while to get used to.
Torgeir Veimo <torgeir at pobox.com>
More information about the cairo