[Cairo] Cairo API change: cairo_get_* -> cairo_current_*

Carl Worth cworth at east.isi.edu
Thu Sep 4 11:24:28 PDT 2003

On Sep 4, Carl Worth wrote:
 > 1) I lifted some of Richard's work on the slim macros to provide
 >    aliases so the deprecated function names will work, but with useful
 >    compile-time warnings. 

Keith pointed out that my magic DEPRECATED macro preserved
source-level compatibility but broke previously compiled code still
expecting the old symbols. I've now fixed it so that the original
deprecated symbols will still be available.


More information about the cairo mailing list