[Cairo] another set of Python bindings

Carl Worth cworth at east.isi.edu
Tue Sep 16 06:59:08 PDT 2003

On Sep 16, tor andersson wrote:
 > On 2003-09-16 CE James Henstridge wrote,
 > > Sounds good.  In case you are interested in shorter names for those 
 > > APIs, the three names I've run into most are "addref", "incref" and just 
 > > "ref".
 > or better yet, though less common: keep and drop.

I like keep/drop quite a bit, (it's always pleasant when a pair of
balancing names have the same number of characters). Unfortunately
we've already got the create/destroy pair and we'll continue to use
destroy to balance calls to the new function.

As for an abbreviated name, the current Cairo API prefers complete
words almost exclusively[*]. So I think I'll stick with "reference" in
spite of its length.

I've now committed cairo_reference and cairo_surface_reference.


[*] The two existing abbreviations I found in a quick scan are in:

and	cairo_rel_*

I think those are probably tolerable, but they might be worth

"Concatenate" would be excessively painful, but perhaps
"cairo_compose_matrix" would be an improvement.

The "rel" abbreviation is harder to eliminate. I don't like
"cairo_relative_move_to". PostScript abbreviates even more with
"rmoveto", but I don't see any pleasant way to do that within an
scheme using '_' characters as word separators.

More information about the cairo mailing list