[Cairo] renaming cairo_concat_matrix
spitzak at d2.com
Wed Sep 17 10:39:34 PDT 2003
Thought I'd try getting this into a new subject.
This is a discussion of how to rename cairo_concat_matrix to use only full
words in all call names.
How about "transform", ie cairo_transform(cairo_t, matrix). Note: no "matrix"
in the name.
This matches cairo_translate(x,y), which is not called
cairo_translate_vector or cairo_translate_xypair or anything like that.
If we want to transform by other types of objects, personally I would like to
see C++ function overloading added to C. Failing that, it seems the standard
is to use very short (and thus abbreviated) trailing names to indicate the
argument types. For instance OpenGL has all the 2f, 3d, 4i, etc type suffixes.
,~,~,~,~ ~ ~ ~ ~
/\_ _|_========___ Bill Spitzak
~~~/\/\\~~~~~~\____________/~~~~~~~~ spitzak at d2.com
More information about the cairo