[Cairo] renaming cairo_concat_matrix
tor.andersson at dsek.lth.se
Wed Sep 17 15:57:13 PDT 2003
Well, postscript uses 'concat' and PDF uses 'cm' which I presume is short
for 'concatenate matrix'. Given the close correspondence between postscript
operators and cairo function calls, I'd think twice before throwing out
that tradition. I suggest cairo_concatenate() or cairo_concatenate_matrix()
despite the rather longish fully spelled out 'concatenate'.
As for rmoveto & co... you're screwed because you insist on separating
words with '_' :)
cairo_relative_move_to() or cairo_rmove_to() look like the two sanest
alternatives. or you can steer away from the postscript name -- which
in these operators is a bit of a misnomer since you're not actually giving
the point you're moving to: cairo_move_by().
More information about the cairo