[Cairo] virtualizing the surface interface

James Henstridge james at daa.com.au
Sat Sep 27 07:34:53 PDT 2003

On 27/09/03 22:07, Carl Worth wrote:

>On Sep 27, James Henstridge wrote:
> > How about cairo_surface_class_t ?  It sounds like the "impl" struct 
> > essentially defines a class of surfaces (in the object oriented
> > sense).
>The problem with that is that then I would naturally use:
>	cairo_surface_class_t *class;
>at which point I start feeling like I'm setting myself up for
>complaints from a C++ user about "class" being a reserved word.
That would only be a problem in the header file though, right?  Some 
possibilities for variable/struct field names could be "surface_class", 
"klass", "class_".  There shouldn't be any problems in the main source 
files though.


Email: james at daa.com.au
WWW:   http://www.daa.com.au/~james/

More information about the cairo mailing list