[cairo] patch for autogen

Carl Worth cworth at cworth.org
Tue Oct 12 11:32:23 PDT 2004

On Mon, 16 Aug 2004 16:19:03 -0700 (PDT), Bryce Harrington wrote:
> I ran into kind of an oddball problem configuring cairo on my gentoo
> system.  When I ran ./autogen.sh for cairo it indicated that my autoconf
> and automake versions were too old, however:


Thanks for reporting this problem.

Sounds like more false negatives in the version checks to me, but I'm
not sure since I don't know exactly which versions we actually require.

> diff -u -p -u -r1.58 configure.in
> --- configure.in        21 Jun 2004 22:13:52 -0000      1.58
> +++ configure.in        16 Aug 2004 23:15:03 -0000
> @@ -1,3 +1,5 @@
> +
> +AC_PREREQ(2.50)
>  AC_INIT(src/cairo.h)

That much seems quite reasonable. If we do need this version (or
greater) of autoconf, then I would greatly prefer to use a supported
means of declaring that rather than rolling our own version check in the

> +# Use automake-1.7 if available.  Some automake installations will try to
> +# provide an earlier version of automake if run without specifying
> +if (automake-1.7 --version) < /dev/null > /dev/null 2>&1 ; then
> +    AUTOMAKE=automake-1.7
> +    ACLOCAL=aclocal-1.7
> +fi

I don't like that at all, since it looks for a specific version rather
than a >= relationship. The right fix here might be to just eliminate
the check in autogen.sh on the version of automake. (See my other recent
post on this subject.)


More information about the cairo mailing list