[cairo] Another win32 build attempt

Jason Dorje Short jdorje at users.sf.net
Mon Apr 11 08:08:31 PDT 2005

Hans Breuer wrote:
> Am 11.04.2005 um 05:35 schrieb Jason Dorje Short:
>> Hans Breuer wrote:
>>> Being enough annoyed of auto*tools versus hand-written
>>> or hand-clicked makefiles I've succesfully tried a different approach 
>>> with cairo.
>> What's wrong with the auto*tools?
> Nothing if you ...
> ... don't want to use the native microsoft compiler

Why can't configure detect the microsoft compiler.

> ... don't care for some (better a lot) extra cpu cycles

Yes, configure is slow.  scons is much faster (but maybe this comes at a 
cost; I dunno).

> ... are able to code in m4 and 'portable shell' to fix it

You have to use automake and autoconf languages, yes.  But any build 
tool will probably make you use its own lanugage.

> ... want to spend hours in waiting for libtool

Is libtool part of autotools?  I thought that was lumped in with GNU 

> ... don't know where your includes and libs are ;-)

That's a good thing right?

>>> And the patch (again including some minor build fixes
>>> for win32) is here:
>>> http://hans.breuer.org/gtk/cairo-2005-04-10-hb.diff
>> I tried running this but I couldn't.
>> First the patch is a bit broken.  -p3 is a very odd patchlevel to use.
> With -p3 it is expeceted to not work. The patch includes files for
> cairo/packaging/cmake as well as for
> pixman/packaging/cmake

But I'm only compiling cairo.

>> Then I got problems because some files were include twice (or so patch 
>> thought).
> CMakeLists.txt for every src directory. Using -p2 is the most to not 
> screw it up.

No, I have to use -p3.  Now I see there is a src/CMakeLists.txt.  When I 
run "cmake src" then cmake runs.  Of course then "make" fails immediately:

jdorje at devon:~/src/cairo$ make
Building dependencies. cmake.depends...
Building object file cairo-array.o...
In file included from /home/jdorje/src/cairo/src/cairoint.h:133,
                  from /home/jdorje/src/cairo/src/cairo-array.c:37:
/home/jdorje/src/cairo/src/cairo-wideint.h:50: error: conflicting types 
for 'int32_t'
/usr/include/sys/types.h:193: error: previous declaration of 'int32_t' 
was here
/home/jdorje/src/cairo/src/cairo-wideint.h:53: error: conflicting types 
for 'uint32_t'
/usr/include/stdint.h:52: error: previous declaration of 'uint32_t' was here
make[1]: *** [cairo-array.o] Error 1
make: *** [default_target] Error 2

>> After applying the patch and installing cmake, I ran "cmake".  No go. 
>> Then I tried "cmake .".  This also didn't work.  Then "cmake 
>> packaging/cmake" also didn't work.
> I haven't tried cmake on command line yet but CMakeSetup works for me.
> You need to select both the source (src) *and* the binary directory
> (packaging/cmake)

I have no CMakeSetup.


More information about the cairo mailing list