[cairo] API Shakeup: cairo_<device>_surface_mark_dirty

Owen Taylor otaylor at redhat.com
Mon Aug 1 11:31:41 PDT 2005

On Mon, 2005-08-01 at 10:44 -0700, Carl Worth wrote:

> >  - I have separate cairo_surface_mark_dirty() and
> >    cairo_surface_mark_rectangle_dirty() functions since I think not
> >    knowing the bounds of the dirty region will be common. Internally
> >    I use negative width/height to flag this case, but I thought that
> >    was ugly to expose in the public API.
> Thanks for not exposing a "magic" meaning for negative numbers here. I
> like the separate function for marking the entire surface dirty. The
> only change I would recommend is to give the two functions a common
> prefix:
> 	cairo_surface_mark_dirty
> 	cairo_surface_mark_dirty_rectangle
> This should also fit in well with the "optional arguments" section of
> the bindings recommendations.

Makes sense to me ... mark_dirty_rectangle() read a little badly to
me, but should be OK. (mark_dirty_with_rectangle()? probably don't
need to get that verbose)

Committed. (In the end, I decided to make cairo_surface_finish() on
an errored surface *not* call surface->backend->flush())


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.freedesktop.org/archives/cairo/attachments/20050801/50006d0d/attachment.pgp

More information about the cairo mailing list