[cairo] Cairo ported to OS/2 - Suggestions
behdad at cs.toronto.edu
Wed Aug 17 03:53:12 PDT 2005
On Wed, 17 Aug 2005, Doodle wrote:
> Bill Spitzak wrote:
> > I would prefer "CAIROEXPORT" over "CAIRODECLSPEC" so that it is a little
> > more clear what it's purpose is. I've also found the best way to control
> > the Win32 dllimport/export mess is to do this:
> > #ifndef CAIROEXPORT
> > # if _WIN32
> > # define CAIROEXPORT __declspec(dllimport)
> > # endif
> > #endif
> > The way Cairo itself is compiled is with
> > -DCAIROEXPORT=__declspec(dllexport). This avoids the need for yet
> > *another* variable (such as the -DBUILD_CAIRO you show).
> Sounds good to me.
Or defining CAIROEXPORT in cairoint.h and bail out if it's
already defined, making sure that cairoint.h is included before
whoever else defining CAIROEXPORT in the public headers. No
command line magic involved.
More information about the cairo