[cairo] Font options patch, first draft
kaffeetisch at gmx.de
Mon Jul 18 15:50:34 PDT 2005
On Mon, 2005-07-18 at 18:08 -0400, Owen Taylor wrote:
> [API proposal]
I just a minor language-bindings related comment.
> /* Stores surface options into @options, overwriting any existing
> * options.
> cairo_surface_get_font_options (cairo_surface_t *surface,
> cairo_font_options_t *options);
I'm not sure this would map well to languages with namespace support:
Getters usually don't modify their arguments -- they just return
something. I'm not really able to come up with a better name right now,
but I think it should be something with 'merge', 'update', 'overwrite'
or something along those lines.
More information about the cairo