[cairo] Font options patch, first draft
cworth at redhat.com
Wed Jul 20 22:14:02 PDT 2005
On Tue, 19 Jul 2005 20:59:15 -0400, Owen Taylor wrote:
> I'm not that fond of making the name of a function reflect memory
> management ... it comes across strange in language bindings.
> For copy_path(), I think "copy" makes sense because there are
> all sorts of behavior difference from what you might expect
> from a getter for the current path... we've converted back to
> user space, etc.
That sounds reasonable to me. Part of my question was aimed at
determining if "copy_path" was a bad name/interface given that you
were rejecting a similar pattern here.
I think you've satisfied me here that its behavior is different enough
to merit the different style.
> The main concerns I had were avoiding the explosion of memory management
> models and keeping things natural for language bindings.
Yes, that's the big one for me too.
It sounds like your patch has the right approach here.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
Url : http://lists.freedesktop.org/archives/cairo/attachments/20050721/c7c7da26/attachment.pgp
More information about the cairo