[cairo] arc_to patch version 0.0.0
cworth at cworth.org
Thu Jul 28 15:19:35 PDT 2005
On Wed, 27 Jul 2005 02:18:49 -0400 (EDT), Behdad Esfahbod wrote:
> I'm attaching a very draft implementation of arc_to. Rough
> around the edges and no documentation, but I wanted to make sure
> I'm on the right track before going on. The patch actually works
> quite good, except for when the arc doesn't fit, that I'm not
> sure should be reported as an error or the radius should be
> decreased. Run the demo and you see what I mean.
I think we should follow the same convention as PostScript
here. Decreasing the radius is just doing some other than what the
application asked for, which doesn't seem that interesting to me.
> The patch includes the sincos patch too. BTW, do you think
> _cairo_cossin is a better name than _cairo_sincos? The reason is
> that normally cos() is associated with x and sin() with y...
_cairo_sincos is definitely better since we're implementing it on top
of the sincos function (when available). Reversing the convention
would just make confusion and likely bugs.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
Url : http://lists.freedesktop.org/archives/cairo/attachments/20050728/4ac4c9e7/attachment.pgp
More information about the cairo