[cairo] Cleaning up the PDF API
cworth at cworth.org
Mon May 16 16:59:29 PDT 2005
On Mon, 16 May 2005 19:36:26 -0400, Kristian Høgsberg wrote:
> Also, what are we trying to achieve here? To reduce the number of
> arguments or to make it easier to use?
Specifically, I want to unify the notion of a "stream" in the cairo
API. Here's what we have right now:
stream == write_func + closure
stream == read_func + closure
stream == write_func + destroy_func + closure
That seems inconsistent and hard-to-remember to me, (independent of
the number of arguments required).
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
Url : http://lists.freedesktop.org/archives/cairo/attachments/20050516/c6941b36/attachment.pgp
More information about the cairo