[cairo] Build problems under Win32/Mingw and Mac OS X 10.3

Tim Teulings rael at edge.ping.de
Thu Aug 10 23:40:06 PDT 2006


I had build problems with the current 1.2.2 version using Win32/Mingw
and Mac OS X 10.3.

Windows: The make file stopped with error while generating cairo.defs. I
tried to replay some of the code in shell manually and this worked (and
the makefile continued).

Mac: The configure script initially detected X11 and Mac OS X support,
which is OK. But the Build failed within the X11 code, not finding some
the various bitmap type defines. After disabling X11 during configure it
still failed in building carbon related code because of a missing
function definition.

I know that this information is not sufficient for bug fixing - but I'm
currently in a hurry (have to go to work :-)). If this bugs are unknown
and somewhere is interested in fixing them, please tell me. I will then
give more detailed information in the evening. I can also check bug
fixes if they are offered as a simple patch or similar (no git on board).


More information about the cairo mailing list