[cairo] cairo-xlib-surface.c:402: _swap_ximage_to_native:Assertion`NOT_REACHED' failed.

Erik Ohrnberger Erik at echohome.org
Fri Dec 1 12:55:41 PST 2006

> > OK, I've returned from out of town, and I'm wondering where this 
> > discussion ended up.
> >
> > Should I start hunting around for a source tarball for 
> cairo-0.1.6 and 
> > it's ebuild file for my gentoo system, or should I hang on and wait 
> > for a patch to test (which I'd be glad to do), or how 
> should I best approach this?
> If you're going to go back to cairo 0.1.6, you'll have to 
> stick with really old versions of GTK+ and friends, too. I 
> don't think they will work with such an old cairo.
> You probably don't want to hear this, but one option is to 
> use a modern Win32 X server that doesn't force you to use 
> 24bpp. XVision has been unsupported for several years, AFAIK. 
> Actually, now that I look it up, XVision's decendant, the 
> "Sun Secure Global Desktop" has the same problem. But there 
> are other Win32 X servers out there you can maybe use as a workaround.
> Regardless, the core problem needs to be solved. Have you 
> tried any of the patches here:
> https://bugs.freedesktop.org/show_bug.cgi?id=4945
> > I also noticed that the bug that I submitted to bugzilla 
> isn't there 
> > anymore.  What happened?
> I still see it:
> https://bugs.freedesktop.org/show_bug.cgi?id=9102
> Dan

OK.  I see the bug report, and it's still there.  Wonder where I went wrong.

Anyway, I tried cygwin, and it works, but appears to draw a significant
demand on the Windows machine.  Are there any other X Servers for Windows XP
that you are ware of, that do not have this bug?

	That would get me around the issues as far ass I can tell.

More information about the cairo mailing list