[cairo] local PLT check failure for cairo-xcb

Jamey Sharp jamey at minilop.net
Mon Oct 2 12:41:44 PDT 2006

On Sat, Sep 30, 2006 at 12:34:05PM -0700, Jamey Sharp wrote:
> Checking .libs/libcairo.so for local PLT entries
> 0005e784  00014307 R_386_JUMP_SLOT   00034af0   cairo_xcb_surface_crea
> FAIL: check-plt.sh
> After looking at cairo-xlib-private.h, I tried adding this line just
> after the #include directives in cairo-xcb-surface.c:
> slim_hidden_proto (cairo_xcb_surface_create_with_xrender_format);
> but that pushed the error to an earlier test:
> Checking cairo.def
> 222d221
> < cairo_xcb_surface_create_with_xrender_format
> FAIL: check-def.sh
> How does this work? cairo_xcb_surface_create_with_xrender_format is used
> inside the implementation but is also public.

On Mon, Oct 02, 2006 at 02:39:10PM -0400, Behdad Esfahbod wrote:
> This means that for some reason that symbols is not correctly find its
> way into cairo.def.  Check why's that.  It all looks correct here.

Thanks for the reply, Behdad, but I don't think you addressed my
question. The cairo.def failure only happened after I tried to use
slim_hidden_proto to address the check-plt failure. Without
slim_hidden_proto, cairo.def is fine, as you observed.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.freedesktop.org/archives/cairo/attachments/20061002/52616e0d/attachment.pgp

More information about the cairo mailing list