[cairo] add solid/gradient pattern info getters

Vladimir Vukicevic vladimirv at gmail.com
Thu Sep 14 17:04:22 PDT 2006

On 9/14/06, Behdad Esfahbod <behdad at behdad.org> wrote:
> Thu, 2006-09-14 at 16:58 -0400, Vladimir Vukicevic wrote:
> > +cairo_public cairo_status_t
> > +cairo_pattern_get_color_stop_rgba (cairo_pattern_t *pattern,
> > +                                  int index, double *offset,
> > +                                  double *red, double *green,
> > +                                  double *blue, double *alpha);
> Thanks Vlad, a lot.  Just wanted to note that having index as the last
> argument means the other arguments are exactly in the order that you
> pass to cairo_pattern_add_color_stop.  But having index right after
> pattern has its own benefits (readability mainly.)

Yeah, I tend to prefer having all the out parameters in a getter be at
the end of the function.

So, does this look good to go?  I'm out of town until tuesday, and can
commit this then if there are no objections (or someone can commit it
for me before then, too).

    - Vlad

More information about the cairo mailing list