[cairo] clip-getters [patch]

Andrew Johnson acjgenius at earthlink.net
Fri Sep 29 17:21:47 PDT 2006

On Sep 29, 2006 6:46 PM Carl Worth wrote:
>I think I like the function name that got pushed
>(cairo_copy_clip_rectangles) more than I would like
>I can imagine we might add a cairo_copy_clip that returns a
>cairo_path_t and then cairo_copy_clip_rectangles would just be a
>variant of that, (much like cairo_copy_path_flat is a variant of
>cairo_copy_path). So keep the variant consistently as a single-word
>would be nice.

I don't usually post on this list, and I don't really care per-say for myself, but I saw this and I wanted to point out  what you said yourself recently in another message. Namely that there should be a consistency in naming with regards to English pluralization. You said that using plurals should be avoided when possible,  except in those cases wherein it's always used as plural, especially considering the non-native English speaking users of the API. Based on that, "rectangles" should not be used, because "rectangle" is already used in the API elsewhere. 

In which case, while from an English perspective rectangles is nicer then rectangle_list, etc, and keeping in mind the single-word variant, it is possibly somewhat inconsistent with existing choices you have made previously I think.

Or it could be that I am possibly being just a bit pedantic.


More information about the cairo mailing list