[cairo] install problem

Daniel Amelang daniel.amelang at gmail.com
Sun Apr 15 11:31:37 PDT 2007

On 4/13/07, ryanc at email.arizona.edu <ryanc at email.arizona.edu> wrote:
> I am trying to install cairo on my x86_64 machine running SuSe 10.2. I have
> tried installing several different versions of cairo and all of them fail. I
> get through the config, but when I run the make command I get all sorts of
> errors. Here is the list of them that comes at the end. There are more that
> come before this as well. If anyone has any ideas on how to fix the problem I'd
> appreciate it. Thanks.
> cairo-xlib-surface.c:129: error: expected specifier-qualifier-list before
> 'XRenderPictFormat'
> cairo-xlib-surface.c:189: error: expected '=', ',', ';', 'asm' or
> '__attribute__' before '*' token
> cairo-xlib-surface.c: In function
> '_cairo_xlib_surface_create_similar_with_format':
> cairo-xlib-surface.c:218: error: 'XRenderPictFormat' undeclared (first use in
> this function)

Looks like it isn't finding the XRender header files. Try installing
whatever suse package it is that has the XRender header files and see
if that helps.


More information about the cairo mailing list