[cairo] cairo - freetype - wxpython and a lot of errors

Wolfgang Eibner we at x-net.at
Mon Sep 10 07:22:30 PDT 2007


I'm software developer in a firm in Austria and we use a wxPython GUI.
There we have some tables/lists and if they are refreshed in a relative
short amount of time, the GUI/X-Server randomly crashes with the
following error:

python: /build/buildd/libcairo-1.2.4/src/cairo-ft-font.c:683:
_cairo_ft_unscaled_font_set_scale: Assertion `error == 0' failed.

We are using Ubuntu Edgy which comes with cairo-1.2.4. I tried some
newer versions of cairo (1.4.4 and 1.4.10) but it seems, that the errors
still appear and I even get some new errors and crashes: "BadLength",
"BadPixmap". I don't know how the ubuntu people compile and configure
their package and which libs it depends on...

My only concern is how to solve this assertion error (and or the other
errors) and how to get a long and stable running GUI for our customers.
I found a patchset from David Turner but I don't know to which version
of cairo it should be applied - I tried it with 1.4.10 but it didn't

Further investigations seem to show, that the other errors also appear
randomly and in the 1.2.4 version which makes it even more worse for me.

Can somebody here help me, please?


Wolfgang Eibner
e: we at x-net.at
t: +43 732 773 142 - 28
m: +43 676 74 81 350
f: +43 732 773 142 - 24
X-Net GmbH
Herrenstrasse 20
4020 Linz

More information about the cairo mailing list