[cairo] 'picking' with Cairo

Kalle Vahlman kalle.vahlman at gmail.com
Tue Aug 5 22:50:35 PDT 2008

2008/8/6 Travis Griggs <tgriggs at cincom.com>:
> On Aug 5, 2008, at 7:05 PM, Carl Worth wrote:
>> PS. People often ask for "picking" and have not managed to find this
>> function yet. Maybe adding the word "picking" to the documentation for
>> cairo_in_fill and cairo_in_stroke would help
> cairo_is_point_in_fill()
> cairo_is_point_in_stroke()
> The use of "is" is a great way to indicate it's a predicate test.

IMO simply adding point is enough to make it a bit more obvious (and
not sound so funny):


"hit testing" is another term used for this (by eg. WebKit), though
that has other uses in game development and physics modelling...

It doesn't really help discoverability to have it documented under
"Drawing" and "The cairo drawing context". If it's technically
feasible, it would help to separate the non-drawing bits from that to
a separate page. These would include for example the in_*() and
*_extents() functions. Those functions are not really drawing, but
inspecting the drawn graphics.

I don't know what would be a descriptive title for those though.

Kalle Vahlman, zuh at iki.fi
Powered by http://movial.fi
Interesting stuff at http://syslog.movial.fi

More information about the cairo mailing list