[cairo] [cairo-commit] font_freeze changes

Richard Hult richard at imendio.com
Wed Oct 22 13:45:58 PDT 2008

Carl Worth wrote:
> On Wed, 2008-10-22 at 20:57 +0100, Chris Wilson wrote:
>> I've tested image/pdf/ps/svg/test*/xlib under linux and I'm confident
>> about the locking there (well, for all the code paths covered by the
>> test suite). I've run make check under win32 as well, but I haven't yet
>> tried that under memfault/lockdep yet (since valgrind is a linux mostly
>> tool, that will require running valgrind on the wine binaries). Quartz
>> I've not even tried compiling, for lack of a host.
> Yes. This is exactly the kind of testing we've had in the past and that
> has led to a 1.x.0 release with broken mutex code for cairo-win32.
> Any volunteers for testing? Would it help if I sent out a snapshot tar
> file?

I'm testing on Quartz quite regularly (for use in GTK+) and latest trunk 
builds and works fine for me. However, I just noticed that make check 
doesn't build, due to using a GNU ld specific option:

ld: unknown option: --allow-shlib-undefined

Last bit of the build is:

gcc -I/opt/gtk/include/librsvg-2 -I/opt/gtk/include/glib-2.0 
-I/opt/gtk/lib/glib-2.0/include -I/opt/gtk/include/gtk-2.0 
-I/opt/gtk/include/cairo -I/opt/gtk/include/pixman-1 
-I/opt/gtk/include/freetype2 -I/opt/gtk/include/libpng12 
-I/opt/gtk/lib/gtk-2.0/include -I/opt/gtk/include/pango-1.0 
-Wl,--allow-shlib-undefined -Wl,-headerpad_max_install_names -o 
.libs/svg2png svg2png-svg2png.o  -L/opt/gtk/lib ./.libs/libcairotest.a

It looks like the check in build/configure.ac.warnings for that options 
isn't effective, at least on Darwin:

configure:25103: checking whether gcc supports -Wl,--allow-shlib-undefined
configure:25117: gcc -c -Werror -Wl,--allow-shlib-undefined  conftest.c >&5
i686-apple-darwin9-gcc-4.0.1: --allow-shlib-undefined: linker input file 
unused because linking not done


More information about the cairo mailing list