[cairo] [PATCH] Fix documentation typos

Fernando Carrijo fcarrijo at yahoo.com.br
Mon Dec 28 22:03:44 PST 2009


Hi list!

Here is a (clearly unpretentious) patch which fixes some documentation
typos I found while browsing Cairo's source code. This is my first post
here, so feel free to warn me if I'm doing something wrong.

---
 src/cairo-recording-surface.c |    8 ++------
 src/cairo.h                   |    8 ++++----
 2 files changed, 6 insertions(+), 10 deletions(-)

diff --git a/src/cairo-recording-surface.c b/src/cairo-recording-surface.c
index c50b330..0532483 100644
--- a/src/cairo-recording-surface.c
+++ b/src/cairo-recording-surface.c
@@ -88,17 +88,13 @@ static const cairo_surface_backend_t cairo_recording_surface_backend;
 /* Currently all recording surfaces do have a size which should be passed
  * in as the maximum size of any target surface against which the
  * recording-surface will ever be replayed.
- *
- * XXX: The naming of "pixels" in the size here is a misnomer. It's
- * actually a size in whatever device-space units are desired (again,
- * according to the intended replay target).
  */
 
 /**
  * cairo_recording_surface_create:
  * @content: the content of the recording surface
- * @extents_pixels: the extents to record in pixels, can be %NULL to record
- *                  unbounded operations.
+ * @extents: the extents to record in pixels, can be %NULL to record unbounded
+ *           operations.
  *
  * Creates a recording-surface which can be used to record all drawing operations
  * at the highest level (that is, the level of paint, mask, stroke, fill
diff --git a/src/cairo.h b/src/cairo.h
index 8be8043..adfb021 100644
--- a/src/cairo.h
+++ b/src/cairo.h
@@ -1096,7 +1096,7 @@ typedef enum _cairo_font_weight {
 /**
  * cairo_subpixel_order_t:
  * @CAIRO_SUBPIXEL_ORDER_DEFAULT: Use the default subpixel order for
- *   for the target device
+ *   the target device
  * @CAIRO_SUBPIXEL_ORDER_RGB: Subpixel elements are arranged horizontally
  *   with red at the left
  * @CAIRO_SUBPIXEL_ORDER_BGR:  Subpixel elements are arranged horizontally
@@ -1236,7 +1236,7 @@ cairo_public cairo_hint_metrics_t
 cairo_font_options_get_hint_metrics (const cairo_font_options_t *options);
 
 /* This interface is for dealing with text as text, not caring about the
-   font object inside the the cairo_t. */
+   font object inside the cairo_t. */
 
 cairo_public void
 cairo_select_font_face (cairo_t              *cr,
@@ -1334,7 +1334,7 @@ cairo_font_face_status (cairo_font_face_t *font_face);
  * @CAIRO_FONT_TYPE_FT: The font is of type FreeType
  * @CAIRO_FONT_TYPE_WIN32: The font is of type Win32
  * @CAIRO_FONT_TYPE_QUARTZ: The font is of type Quartz (Since: 1.6)
- * @CAIRO_FONT_TYPE_USER: The font was create using cairo's user font api (Since: 1.8)
+ * @CAIRO_FONT_TYPE_USER: The font was created using cairo's user font api (Since: 1.8)
  *
  * #cairo_font_type_t is used to describe the type of a given font
  * face or scaled font. The font types are also known as "font
@@ -2261,7 +2261,7 @@ cairo_pattern_set_user_data (cairo_pattern_t		 *pattern,
  * cairo_pattern_type_t:
  * @CAIRO_PATTERN_TYPE_SOLID: The pattern is a solid (uniform)
  * color. It may be opaque or translucent.
- * @CAIRO_PATTERN_TYPE_SURFACE: The pattern is a based on a surface (an image).
+ * @CAIRO_PATTERN_TYPE_SURFACE: The pattern is based on a surface (an image).
  * @CAIRO_PATTERN_TYPE_LINEAR: The pattern is a linear gradient.
  * @CAIRO_PATTERN_TYPE_RADIAL: The pattern is a radial gradient.
  *
-- 
1.5.6.3



More information about the cairo mailing list