[cairo] Renaming cairo_meta_surface_t?

M Joonas Pihlaja jpihlaja at cc.helsinki.fi
Wed Jul 8 06:27:21 PDT 2009


In cairo master the cairo_meta_surface_t type has recently been made a 
public surface type.  I think this is a sorely missed API addition so 
wholeheartedly agree with making it public, but the name could be 
better; cairo_meta_surface_t is a particularly nondescriptive name for 
a public surface type.  I propose it be renamed to something like 
cairo_recording_surface_t or cairo_replay_surface_t instead.  The 
public functions would then be, for example:

cairo_recording_surface_create (content, width, height)
cairo_recording_surface_ink_extents (surface, &x, &y, &width, &height)
cairo_recording_surface_replay (surface, target_surface);



More information about the cairo mailing list