[cairo] Extending Cairo API to support reusable paths
matt.woodrow at gmail.com
Mon Apr 19 22:12:57 PDT 2010
I'd agree in some ways, but this is keeping in style with how the
current surface pointers are passed.
Creating an otherwise empty wrapper object or a typedef could make the
code more readable at least.
On 20/04/10 4:14 PM, M Joonas Pihlaja wrote:
>> * Creates a backend specific path object from the current path data
>> const void *
>> (*build_path_object) (cairo_path_fixed_t *path,
>> cairo_gstate_t *gstate);
> [snip more void pointers]
> This gives me pimples. The returned pointer type ought to be typed,
> so that the responsibility of keeping track of types is with the
> implementor rather than the user of these APIs. It's okay to be a
> completely opaque type imho, but not one that says "whatevah, I do
> what I want!" one.
More information about the cairo