[cairo] When printing, chars are replaced with square graphic char

Roger rogerx.oss at gmail.com
Mon Sep 19 15:27:36 PDT 2011

> On Sun, Sep 11, 2011 at 02:56:19PM +0930, Adrian Johnson wrote:
>On 11/09/11 08:10, Roger wrote:
>> Anyways, I created a new document within Abiword using "Time New Roman"
>> $ fc-match "Time New Roman"
>> DejaVuSans.ttf: "DejaVu Sans" "Book"
>> I then typed the "A B C D ..., a b c ..., 1 2 3 ..., ! @ # ..." and copied the
>> lines several times.  The very last comma symbol "... ? / . ," was replaced
>> with the rectangle glyph.
>> Attached is the /tmp/printout.
>Your printout file has been converted from PDF to PS using pdftops. If
>you are using gtk 2.24 or later AbiWord has printed the file in PDF
>format. There are a few things you can try to narrow down the cause of
>this bug.
>1. Print from AbiWord to a PS file and print the PS file bypassing CUPS
>lpr -o raw print.ps
>2. Print from AbiWord to a PDF file, convert to PS then print:
>pdftops -level2 print.pdf
>lpr -o raw print.ps
>pdftops -level3 print.pdf
>lpr -o raw print.ps
>Your printout has been converted from PDF to level 3 PS. The font is
>embedded as a CID font. If you convert to level 2 PS, CID fonts will not
>be used. It could be that the your printer has a problem with CID fonts.
>I found a couple of similar bug reports:
>I tried printing your printout on my Xerox printer which has an Adobe
>PostScript 3 interpreter and it printed correctly.

Just an FYI, as soon as I started printing using Postscript Level 2 instead of
3, it seemed to resolve the problem.

However, a few days later, the printer software/display froze requiring a hard
power reset.  And then a few hours later, again it would freeze with "HP >>"
and have confirmed through HP support it is a bad formatter board -- described
on other Internet forums as a bad formatter board as well.

Appears, this bad char printing problem was occurring silently for the past 6+
months when using Postscript Level 3, nor did I even suspect it was hardware

I've reset the firmware per HP instructions and am now just waiting to see if
this problem resolves itself for sure, before shipping things back from Alaska
($200) or paying a $70 charge to get a refurbished replacement. (Technically,
I shouldn't have to pay anything from what I understand.)

I'll follow-up after finalizing my troubleshooting along with the results of
getting this solved.


More information about the cairo mailing list