[cairo] [PATCH 0/4] Minor test cleanups
Uli Schlachter
psychon at znc.in
Fri Sep 13 04:03:43 PDT 2013
Hi,
On 13.09.2013 00:55, Bryce W. Harrington wrote:
> A few nit picks I noticed during recent test work.
>
> Bryce Harrington (4):
> gitignore: Ignore build chaff when configuring with --enable-gtk-doc
> test: Comma separate keywords
> test: Space out keywords for clarity
> test: Document use of -k and CAIRO_TEST_TARGET to run test subsets
>
> .gitignore | 2 ++
> test/README | 6 ++++++
> test/a1-bug.c | 2 +-
> test/arc-direction.c | 2 +-
> test/caps-joins-curve.c | 2 +-
> test/caps-tails-curve.c | 2 +-
> test/caps.c | 8 ++++----
> test/clip-empty-group.c | 2 +-
> test/drunkard-tails.c | 2 +-
> test/image-bug-710072.c | 4 ++--
> test/joins.c | 2 +-
> test/mesh-pattern-accuracy.c | 2 +-
> test/mesh-pattern-conical.c | 2 +-
> test/mesh-pattern-control-points.c | 2 +-
> test/mesh-pattern-fold.c | 2 +-
> test/mesh-pattern-overlap.c | 2 +-
> test/mesh-pattern-transformed.c | 2 +-
> test/mesh-pattern.c | 2 +-
> test/partial-coverage.c | 22 +++++++++++-----------
> test/record1414x.c | 4 ++--
> test/rectilinear-dash-scale.c | 4 ++--
> test/rectilinear-dash.c | 2 +-
> test/scale-offset-image.c | 2 +-
> test/scale-offset-similar.c | 2 +-
> test/unclosed-strokes.c | 2 +-
> 25 files changed, 47 insertions(+), 39 deletions(-)
All four patches merged and pushed. However, I am not totally happy with the
last one. Let me quote the current test/README a bit:
> The test suite is built as a single binary, which allows you to choose
> individual or categories of tests to run. For example, if you want to
> run all text related tests you can use:
> ./cairo-test-suite text
> Or if you want to check the current status of known failures:
> ./cairo-test-suite XFAIL
[Now follows the new text from patch 4]
> Or to run a subset of tests, use the -k option to run only the tests
> that include the given keyword:
> ./cairo-test-suite -k downscale
> The binary also permits controlling which backend is used via the
> CAIRO_TEST_TARGET environment variable, so for instance:
> CAIRO_TEST_TARGET=gl ./cairo-test-suite -k blur
> This binary should be backwards-compatible with all library versions,
> allowing you to compare current versus past behaviour for any test.
>
> Tailoring tests running
> -----------------------
> There are some mechanisms to limit the tests run during "make test".
> These come very handy when doing development, but should not be used
> to circumvent the "pass" requirements listed below.
>
> To limit the backends that the tests are run against, use the
> TARGETS make variable, that can also be passed to make.
> It should contain a (space-, comma-, etc-separated) list of backends to test.
> To limit the tests run, use the CAIRO_TESTS environment variable, which
> should be a space-separated list of tests to run. For example:
>
> CAIRO_TESTS="zero-alpha" make test TARGETS=image,ps
As can be seen, the next section basically describes the same thing as the new
text, but it calls the test suite in a different way.
I merged this anyway, mostly because I don't like calling cairo-test-suite
through make check ever since an automake upgrade made "make check" silent and
only printing a summary of the test results. In cairo's case, this means that it
only says "one test failed" which is completely useless.
I tried looking into ways around this, but haven't found anything convincing
(and backwards compatible to older automake versions).
So I noticed the above ugliness in the README, but I don't care enough and will
forget about it again in 3.. 2.. 1..
Cheers,
Uli
--
Bitte nicht mit dem verbleibenden Auge in den Laser gucken.
- Vincent Ebert
More information about the cairo
mailing list