[cairo] [PATCH 00/41] DRM backend fixes - take 1
Uli Schlachter
psychon at znc.in
Fri Dec 11 09:00:47 PST 2015
Am 10.12.2015 um 23:16 schrieb Enrico Weigelt, metux IT consult:
>
> Hi folks,
>
>
> I'm currently in process of reparing the currently broken DRM backend.
> It's far from being finished - several source files dont even compile
> yet, but a few things might alreay be ready for review.
>
>
> --mtx
>
> Enrico Weigelt, metux IT consult (41):
> core: some helper macros for easier access to box dimensions
> core: reintroduce bot-scan-converter functions
> core: _canonical_box() allow NULL box ptr
> drm: use typedefs and defines from drm.h instead of redundant own
> definitions
> drm/intel: fixed missing includes
> drm/intel: fixed cairo_status_t vs cairo_int_status_t mixup
> drm/intel: fixed const constraints
> drm/intel: fixed prototype of surface_backend => show_glyphs()
> operations
> drm/intel: consolidated INTEL_GLYPH_CACHE_* with GLYPH_CACHE_*
> drm/intel: fixed call to _cairo_surface_init()
> drm/intel: fixed surface backend ops vectors
> drm/intel: fixed call to surface->drm.base.backend->flush() operation
> drm/intel: renamed intel_glyph_cache_add_glyph()::glyph to
> glyph_private
> drm/intel: intel_scaled_glyph_fini(): renamed local priv variable for
> better consistency
> drm/intel: fixed prototyp of intel_scaled_glyph_fini()
> drm/intel: store scaled_glyph pointer in intel_glyph structure
> drm/intel: make struct _intel_glyph container of
> cairo_scaled_glyph_private_t
> drm/intel: destructor for glyph cache node
> drm/intel: fix font cleanup
> drm/intel: allow CAIRO_FORMAT_RGB30 in intel_bo
> drm/i915: fixed missing includes
> drm/i915: fixed cairo_status_t vs cairo_int_status_t mixup
> drm/i915: fixed calls to _cairo_composite_rectangles_init_for_paint()
> drm/i915: fixed const constraints
> drm/i915: fixed prototype of surface_backend => show_glyphs()
> operations
> drm/i915: fixed missing antialiasing mode parameters
> drm/i915: fixed call to _cairo_composite_rectangles_init_for_mask()
> drm/i915: fixed call to _cairo_composite_rectangles_init_for_stroke()
> drm/i915: fixed surface backend ops vectors
> drm/i915: fixed calls to _cairo_clip_get_region()
> drm/i915: fixup call to _cairo_boxes_extents()
> drm/i915: split image_caches array into struct for better readability
> drm/i915: allow CAIRO_FORMAT_RGB30 in image cache
> drm/i915: fixed _cairo_clip_*() calls
> drm/i915: replace use of _cairo_clip_to_boxes()
> drm/i915: fixed call to _cairo_botor_scan_converter_add_polygon()
> drm/i915: fixed test for whether path is a box
> drm/i915: fixed call to _cairo_composite_rectangles_init_for_glyphs
> drm/i965: fixed _cairo_clip_*() calls
> drm/i965: fixed calls to _cairo_composite_rectangles_init_for_paint()
> qt: replaced calls to _cairo_clip_init_copy() by _cairo_clip_copy()
>
> src/cairo-botor-scan-converter.c | 36 +++++
> src/cairo-box-inline.h | 3 +
> src/cairo-path-fixed.c | 3 +
> src/cairo-qt-surface.cpp | 2 +-
> src/cairo-spans-private.h | 4 +
> src/drm/cairo-drm-bo.c | 30 +---
> src/drm/cairo-drm-i915-glyphs.c | 56 +++----
> src/drm/cairo-drm-i915-private.h | 14 +-
> src/drm/cairo-drm-i915-shader.c | 2 +-
> src/drm/cairo-drm-i915-spans.c | 2 +-
> src/drm/cairo-drm-i915-surface.c | 304 +++++++++++++++-----------------------
> src/drm/cairo-drm-i965-glyphs.c | 16 +-
> src/drm/cairo-drm-i965-surface.c | 30 ++--
> src/drm/cairo-drm-intel-private.h | 13 +-
> src/drm/cairo-drm-intel-surface.c | 72 ++++-----
> src/drm/cairo-drm-intel.c | 111 +++++++++-----
> 16 files changed, 324 insertions(+), 374 deletions(-)
Thanks for working on this. I looked through this and it mostly looks good to me.
--
"Are you preparing for another war, Plutarch?" I ask.
"Oh, not now. Now we're in that sweet period where everyone agrees that our
recent horrors should never be repeated," he says. "But collective thinking is
usually short-lived. We're fickle, stupid beings with poor memories and a great
gift for self-destruction.
More information about the cairo
mailing list