[cairo] [PATCH 01/41] core: some helper macros for easier access to box dimensions

Enrico Weigelt, metux IT consult enrico.weigelt at gr13.net
Fri Dec 11 21:20:02 PST 2015

On 11.12.2015 17:43, Uli Schlachter wrote:

> The patch as-is just introduces unused definitions. I'd squash this into the
> patch that uses this.

I have a bad feeling w/ that idea, because later patches could also
use it. Now when the previous patch is removed, things break.

> This evaluates the macro argument twice and doesn't even protect the
> evaluations. Could you add least replace box with (box)?

fixed. will post it in the next take.


Enrico Weigelt,
metux IT consulting

More information about the cairo mailing list