[cairo] [PATCH 00/36] DRM backend fixes / take 2

Enrico Weigelt, metux IT consult enrico.weigelt at gr13.net
Sat Dec 12 10:51:28 PST 2015

Hi folks,

here's the second take of my DRM backend fixes for review

* incorporated suggestions from prev review
* squashed some patches of same topic in individual backends
  (generic intel, i915, i965)
* added some more fixes for i965

Would be nice if you guys could give my your signed-off for
patches that are okay / ready for mainline.


Enrico Weigelt, metux IT consult (36):
  core: some helper macros for easier access to box dimensions
  core: reintroduce bot-scan-converter functions
  core: allow NULL parameter for _cairo_path_fixed_is_box()
  drm: use typedefs and defines from drm.h instead of redundant own
  drm: add helper for typecasting from abstract surface to drm surface
  drm: fixed missing includes
  drm: fixed cairo_status_t vs cairo_int_status_t mixup
  drm: fixed const constraints
  drm: allow CAIRO_FORMAT_RGB30
  drm: fixed missing antialiasing mode parameters
  drm: fixed call to _cairo_composite_rectangles_init_for_*()
  drm: fixed prototype of surface_backend => show_glyphs() operations
  drm: fixed surface backend ops vectors
  drm: fixed calls to _cairo_botor_scan_converter_add_polygon()
  drm: fixed handling of private pointers in scaled_font objects
  drm: fixed test for whether path is a box
  drm/intel: consolidated INTEL_GLYPH_CACHE_* with GLYPH_CACHE_*
  drm/intel: fixed call to _cairo_surface_init()
  drm/intel: fixed call to surface->drm.base.backend->flush() operation
  drm/intel: renamed intel_glyph_cache_add_glyph()::glyph to
  drm/intel: intel_scaled_glyph_fini(): renamed local priv variable for
    better consistency
  drm/intel: fixed prototyp of intel_scaled_glyph_fini()
  drm/intel: store scaled_glyph pointer in intel_glyph structure
  drm/intel: make struct _intel_glyph container of
  drm/intel: destructor for glyph cache node
  drm/intel: fix font cleanup
  drm/i915: fixed prototype of surface_backend => show_glyphs()
  drm/i915: fixed surface backend ops vectors
  drm/i915: fixed calls to _cairo_clip_get_region()
  drm/i915: fixup call to _cairo_boxes_extents()
  drm/i915: split image_caches array into struct for better readability
  drm: fixed _cairo_clip_*() calls
  drm: replace use of _cairo_clip_to_boxes()
  drm/i915: fixed call to _cairo_pattern_sampled_area()
  drm/i915: fixed call to intel_surface_flush()
  qt: replaced calls to _cairo_clip_init_copy() by _cairo_clip_copy()

 src/cairo-botor-scan-converter.c  |  36 +++++
 src/cairo-box-inline.h            |   3 +
 src/cairo-path-fixed.c            |   3 +-
 src/cairo-qt-surface.cpp          |   2 +-
 src/cairo-spans-private.h         |   4 +
 src/drm/cairo-drm-bo.c            |  30 +---
 src/drm/cairo-drm-i915-glyphs.c   |  95 +++++++-----
 src/drm/cairo-drm-i915-private.h  |  29 +++-
 src/drm/cairo-drm-i915-shader.c   |   7 +-
 src/drm/cairo-drm-i915-spans.c    |   9 +-
 src/drm/cairo-drm-i915-surface.c  | 318 ++++++++++++++++----------------------
 src/drm/cairo-drm-i965-glyphs.c   |  76 +++++----
 src/drm/cairo-drm-i965-private.h  |  24 ++-
 src/drm/cairo-drm-i965-shader.c   |   2 +-
 src/drm/cairo-drm-i965-spans.c    |   2 +-
 src/drm/cairo-drm-i965-surface.c  | 247 ++++++++++-------------------
 src/drm/cairo-drm-intel-private.h |  26 +++-
 src/drm/cairo-drm-intel-surface.c |  83 ++++------
 src/drm/cairo-drm-intel.c         | 115 +++++++++-----
 src/drm/cairo-drm-private.h       |   6 +
 src/drm/cairo-drm-surface.c       |   4 +-
 21 files changed, 543 insertions(+), 578 deletions(-)


More information about the cairo mailing list