[cairo] [PATCH 50/51] core: changed retval of _cairo_composite_rectangles_init_for_mask() to cairo_bool_t

Chris Wilson chris at chris-wilson.co.uk
Mon Dec 21 04:41:48 PST 2015

On Fri, Dec 18, 2015 at 02:29:29PM +0100, Enrico Weigelt, metux IT consult wrote:

Honestly, I prefer the interface to be consistent (i.e. all the
functions for the operations return the same type), consistent in error
propagation, and returning the status allows for more flexibilty in

At the moment the callsites are essentially:

	test; cjmp; undo stack; ret

afterwards they become;

	test; cjmp; undo stack; mov NOTHING_TO_DO, eax; ret

or more likely;
	test; cjmp -> ret
	test; cjmp; mov NOTHING_TO_DO, eax; jmp -> ret

Chris Wilson, Intel Open Source Technology Centre

More information about the cairo mailing list