[cairo] [PATCH 00/54] DRM + core fixes - v5
Enrico Weigelt, metux IT consult
enrico.weigelt at gr13.net
Wed Dec 23 02:22:44 PST 2015
Hi folks,
here's the 5th version of my drm fixes patchset
* incorporated stuff from last review round
* reworked the typecasting helpers
* generalized bo mmap and munmap
* dropped more copy+paste from libdrm
--mtx
Enrico Weigelt, metux IT consult (54):
core: some helper macros for easier access to box dimensions
core: reintroduce bot-scan-converter functions
core: allow NULL parameter for _cairo_path_fixed_is_box() and
_cairo_path_fixed_is_stroke_box()
core: fix compiler warnings
core: helper function for converting cairo_status_t to human-readable
text (like strerror)
core: helper inline for rect->box conversion
core: some in-code documentation
core: dropped actually unused parameter of _cairo_boxes_to_array()
core: fixed code duplication
core: dropped unnecessary local variable in
_cairo_composite_rectangles_intersect()
core: changed retval of _cairo_composite_rectangles_intersect() to
cairo_bool_t
core: helper funtion for initializing rects with zero
tests: fixed warnings on unused variables
dropped autogenerated files
drm: use typedefs and defines from drm.h instead of redundant own
definitions
drm: typecasting helpers
drm: fixed missing includes
drm: fixed cairo_status_t vs cairo_int_status_t mixup
drm: fixed const constraints
drm: allow CAIRO_FORMAT_RGB30
drm: fixed missing antialiasing mode parameters
drm: fixed call to _cairo_composite_rectangles_init_for_*()
drm: fixed prototype of surface_backend => show_glyphs() operations
drm: fixed surface backend ops vectors
drm: fixed calls to _cairo_botor_scan_converter_add_polygon()
drm: fixed handling of private pointers in scaled_font objects
drm: fixed test for whether path is a box
drm: fixed return value of _device_flush()
drm: made various drm-backends optional (buildtime)
drm: fixed call to _cairo_atomic_ptr_cmpxchg()
drm: cleaned up device probing / initialization
drm: fixed surface backend ops vectors
drm: fixed calls to surface backend flush() operations
drm: fixed prototypes of surface_backend => show_glyphs() operations
drm: fixed calls to _cairo_surface_init()
drm: generalized bo unmap
drm: generalized *_bo_map functions
drm/intel: consolidated INTEL_GLYPH_CACHE_* with GLYPH_CACHE_*
drm/intel: renamed intel_glyph_cache_add_glyph()::glyph to
glyph_private
drm/intel: intel_scaled_glyph_fini(): renamed local priv variable for
better consistency
drm/intel: fixed prototyp of intel_scaled_glyph_fini()
drm/intel: store scaled_glyph pointer in intel_glyph structure
drm/intel: make struct _intel_glyph container of
cairo_scaled_glyph_private_t
drm/intel: destructor for glyph cache node
drm/intel: fix font cleanup
drm/i915: fixed calls to _cairo_clip_get_region()
drm/i915: fixup call to _cairo_boxes_extents()
drm/i915: split image_caches array into struct for better readability
drm: fixed _cairo_clip_*() calls
drm: replace use of _cairo_clip_to_boxes()
drm/i915: fixed call to _cairo_pattern_sampled_area()
qt: replaced calls to _cairo_clip_init_copy() by _cairo_clip_copy()
drm/intel: optimized loops and fixed warning
drm/intel: fixed unitialized variable warning and improved error
handling
.gitignore | 5 +
boilerplate/Makefile.win32.features | 523 -------------------------
build/Makefile.win32.features | 41 --
build/Makefile.win32.features-h | 130 -------
configure.ac | 26 ++
src/Makefile.sources | 55 ++-
src/Makefile.win32.features | 661 --------------------------------
src/cairo-botor-scan-converter.c | 38 +-
src/cairo-box-inline.h | 13 +
src/cairo-boxes-private.h | 3 +-
src/cairo-boxes.c | 31 +-
src/cairo-clip-boxes.c | 61 +--
src/cairo-composite-rectangles.c | 46 ++-
src/cairo-error.c | 50 +++
src/cairo-line.c | 8 +-
src/cairo-path-bounds.c | 3 +-
src/cairo-path-fixed.c | 9 +-
src/cairo-polygon-intersect.c | 2 +-
src/cairo-polygon-reduce.c | 2 +-
src/cairo-qt-surface.cpp | 2 +-
src/cairo-spans-private.h | 4 +
src/cairo.h | 2 +
src/cairoint.h | 6 +
src/drm/cairo-drm-bo.c | 49 +--
src/drm/cairo-drm-gallium-surface.c | 2 +-
src/drm/cairo-drm-i915-glyphs.c | 97 +++--
src/drm/cairo-drm-i915-private.h | 48 ++-
src/drm/cairo-drm-i915-shader.c | 30 +-
src/drm/cairo-drm-i915-spans.c | 9 +-
src/drm/cairo-drm-i915-surface.c | 379 ++++++++----------
src/drm/cairo-drm-i965-glyphs.c | 78 ++--
src/drm/cairo-drm-i965-private.h | 31 +-
src/drm/cairo-drm-i965-shader.c | 46 +--
src/drm/cairo-drm-i965-spans.c | 2 +-
src/drm/cairo-drm-i965-surface.c | 264 +++++--------
src/drm/cairo-drm-intel-debug.c | 211 +++++-----
src/drm/cairo-drm-intel-ioctl-private.h | 403 +------------------
src/drm/cairo-drm-intel-private.h | 84 +++-
src/drm/cairo-drm-intel-surface.c | 107 +++---
src/drm/cairo-drm-intel.c | 153 +++++---
src/drm/cairo-drm-ioctl-private.h | 12 -
src/drm/cairo-drm-private.h | 50 ++-
src/drm/cairo-drm-radeon-private.h | 107 +++++-
src/drm/cairo-drm-radeon-surface.c | 105 ++---
src/drm/cairo-drm-radeon.c | 152 +-------
src/drm/cairo-drm-surface.c | 4 +-
src/drm/cairo-drm.c | 203 +++++-----
test/any2ppm.c | 3 +
test/create-for-stream.c | 23 +-
49 files changed, 1415 insertions(+), 2958 deletions(-)
delete mode 100644 boilerplate/Makefile.win32.features
delete mode 100644 build/Makefile.win32.features
delete mode 100644 build/Makefile.win32.features-h
delete mode 100644 src/Makefile.win32.features
delete mode 100644 src/drm/cairo-drm-ioctl-private.h
--
2.6.4.442.g545299f
More information about the cairo
mailing list