[cairo] [PATCH 11/72] core: changed retval of _cairo_composite_rectangles_intersect() to cairo_bool_t
chris at chris-wilson.co.uk
Tue Dec 29 06:23:29 PST 2015
On Tue, Dec 29, 2015 at 10:16:49AM +0100, Enrico Weigelt, metux IT consult wrote:
> This function only has two possible return states - success and
> nothing to do. We just need 1 bit for that. Replacing the big enum
> by bool makes the code smaller and easier to understand (dont need to
> consider other possible values of cairo_int_state_t anymore)
> The same applies to several callers - they'll be changed in subsequent patches.
But not all paths of very similar functions. Having the sematically
similar functions have consistent interfaces is much more important, nor
have you demonstrated any benefit from the churn.
Chris Wilson, Intel Open Source Technology Centre
More information about the cairo