[cairo] [PATCH 72/72] HACK: drm: dumb framebuffer support

Enrico Weigelt, metux IT consult enrico.weigelt at gr13.net
Tue Dec 29 07:42:41 PST 2015

On 29.12.2015 15:57, Chris Wilson wrote:
> On Tue, Dec 29, 2015 at 10:17:50AM +0100, Enrico Weigelt, metux IT consult wrote:
>> Seems to be already functional, but yet quite rudimentary.
> I'd be careful with the naming here and stick with "dumb". The important
> point is that we cannot derive from this surface for anything that uses
> acceleration (at least not in a generic manner) and at the moment that
> knowledge is tied into "dumb". Unless you are planning to switch away from
> dumb KMS framebuffers of couse.

Well, naming isn't really consistent yet ("dumb" vs. "basic"). I'm
planning to rename it in a later iteration.

I've already used the naming "dumb" for certain functions, which are
also used by radeon backend, but dont actually use any GPU functions
(just proxy to the underlying image surface)

Any suggestions on a proper naming ?


Enrico Weigelt,
metux IT consulting

More information about the cairo mailing list