[Cairo] renaming cairo_concat_matrix
sven.luther at wanadoo.fr
Wed Sep 17 10:57:11 PDT 2003
On Wed, Sep 17, 2003 at 01:53:10PM -0400, Carl Worth wrote:
> On Sep 17, Bill Spitzak wrote:
> > This is a discussion of how to rename cairo_concat_matrix to use only full
> > words in all call names.
> > How about "transform", ie cairo_transform(cairo_t, matrix). Note: no "matrix"
> > in the name.
> In isolation this seems a fine name. But, there are several other
> functions that already have matrix in the name:
> cairo_set_matrix (cairo_t *cr, cairo_matrix_t *matrix);
> cairo_default_matrix (cairo_t *cr);
> /* XXX: There's been a proposal to add cairo_default_matrix_exact */
> cairo_identity_matrix (cairo_t *cr);
> Any proposal should consider these as well.
> Of these, the trickiest aspect is differentiating the current
> cairo_set_matrix (which installs a new transformation) and the current
> cairo_concat_matrix (which modifies the current transformation
> according to the given matrix).
More information about the cairo