[Cairo] renaming cairo_concat_matrix
spitzak at d2.com
Wed Sep 17 12:23:14 PDT 2003
On Wednesday 17 September 2003 10:53 am, Carl Worth wrote:
> In isolation this seems a fine name. But, there are several other
> functions that already have matrix in the name:
> cairo_set_matrix (cairo_t *cr, cairo_matrix_t *matrix);
> cairo_default_matrix (cairo_t *cr);
> /* XXX: There's been a proposal to add cairo_default_matrix_exact */
> cairo_identity_matrix (cairo_t *cr);
> Any proposal should consider these as well.
> Of these, the trickiest aspect is differentiating the current
> cairo_set_matrix (which installs a new transformation) and the current
> cairo_concat_matrix (which modifies the current transformation
> according to the given matrix).
By that logic cairo_translate() should be called cairo_translate_matrix().
Since I don't think anybody wants that, I don't see any problem with
Also cairo_concatenate() might make sense.
,~,~,~,~ ~ ~ ~ ~
/\_ _|_========___ Bill Spitzak
~~~/\/\\~~~~~~\____________/~~~~~~~~ spitzak at d2.com
More information about the cairo