[Cairo] Suggestion for replacing cairo_copy with set_gstate.

Carl Worth cworth at east.isi.edu
Tue Sep 30 09:28:46 PDT 2003

On Sep 26, Bill Spitzak wrote:
 > > Perhaps instead we just want a single function to copy the graphics
 > > state from one cairo_t to another. Perhaps drop cairo_copy and add
 > > something like:
 > >
 > > 	cairo_set_graphics_state (cr, copy);
 > Yes this is exactly how I think this should be done, though in some email I 
 > was writing I used the name cairo_copy_state(cairo_t* to, cairo_t*
 > from).

Actually, we might as well go all the way to:

	cairo_copy (cairo_t *dst, cairo_t *src);

I think that should be clear enough without the words "graphics" or

It sounds like there's good consensus for this change now. I'll go
ahead and do this.


More information about the cairo mailing list